See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/183/changes>

Changes:

[gboue] [MENFORCER-204] Add new rule: should be able to make sure that project 
artifact is a Snapshot

Adding a RequireSnapshotVersion rule, which is the opposite of the 
RequireReleaseVersion rule.

------------------------------------------
[...truncated 754 lines...]
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
       |        Running post-build script: 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-upper-bound-deps_failure/verify.groovy>
       
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-upper-bound-deps_failure/build.log>
[INFO] Building: dependencies_not_converging_test_scope/pom.xml
[INFO] ..SUCCESS (0.2 s)
[INFO] Building: ban-distribution-management/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/ban-distribution-management/build.log>
 for details.
[INFO] Building: require-files-dont-exist/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-files-dont-exist/build.log>
 for details.
[INFO] Building: require-same-versions_success/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-same-versions_success/build.log>
 for details.
[INFO] Building: require-active-profile/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-active-profile/build.log>
 for details.
[INFO] Building: ban-transitive-dependencies-fail/pom.xml
[INFO] run script verify.groovy
[INFO] ..FAILED (0.2 s)
[INFO]   The post-build script did not succeed. assert buildLog.text.contains( 
'[WARNING] Rule 0: org.apache.maven.plugins.enforcer.BanTransitiveDependencies 
failed with message:' )
       |        |    |
       |        |    false
       |        Exception in thread "main" 
java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : 
Unsupported major.minor version 51.0
       |                at java.lang.ClassLoader.defineClass1(Native Method)
       |                at 
java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
       |                at 
java.lang.ClassLoader.defineClass(ClassLoader.java:615)
       |                at 
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
       |                at 
java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
       |                at 
java.net.URLClassLoader.access$000(URLClassLoader.java:58)
       |                at 
java.net.URLClassLoader$1.run(URLClassLoader.java:197)
       |                at java.security.AccessController.doPrivileged(Native 
Method)
       |                at 
java.net.URLClassLoader.findClass(URLClassLoader.java:190)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClassFromSelf(ClassRealm.java:401)
       |                at 
org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:42)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadClass(ClassRealm.java:271)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:254)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:239)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.getMainClass(Launcher.java:144)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:266)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
       |        Running post-build script: 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/ban-transitive-dependencies-fail/verify.groovy>
       
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/ban-transitive-dependencies-fail/build.log>
[INFO] Building: require-maven-version/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-maven-version/build.log>
 for details.
[INFO] Building: require-upper-bound-dependencies-unique_failure/pom.xml
[INFO] run script verify.groovy
[INFO] ..FAILED (0.2 s)
[INFO]   The post-build script did not succeed. assert buildLog.text.contains( 
'Rule 0: org.apache.maven.plugins.enforcer.RequireUpperBoundDeps failed with 
message:' )
       |        |    |
       |        |    false
       |        Exception in thread "main" 
java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : 
Unsupported major.minor version 51.0
       |                at java.lang.ClassLoader.defineClass1(Native Method)
       |                at 
java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
       |                at 
java.lang.ClassLoader.defineClass(ClassLoader.java:615)
       |                at 
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
       |                at 
java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
       |                at 
java.net.URLClassLoader.access$000(URLClassLoader.java:58)
       |                at 
java.net.URLClassLoader$1.run(URLClassLoader.java:197)
       |                at java.security.AccessController.doPrivileged(Native 
Method)
       |                at 
java.net.URLClassLoader.findClass(URLClassLoader.java:190)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClassFromSelf(ClassRealm.java:401)
       |                at 
org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:42)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadClass(ClassRealm.java:271)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:254)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:239)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.getMainClass(Launcher.java:144)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:266)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
       |        Running post-build script: 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-upper-bound-dependencies-unique_failure/verify.groovy>
       
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-upper-bound-dependencies-unique_failure/build.log>
[INFO] Building: require-upper-bound-deps_success/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-upper-bound-deps_success/build.log>
 for details.
[INFO] Building: require-release-dependencies-excludes/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-release-dependencies-excludes/build.log>
 for details.
[INFO] Building: dependencies_converge/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/dependencies_converge/build.log>
 for details.
[INFO] Building: banned-plugins/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/banned-plugins/build.log>
 for details.
[INFO] Building: banned-dependencies-versionrange-fail/pom.xml
[INFO] run script verify.groovy
[INFO] ..FAILED (0.2 s)
[INFO]   The post-build script did not succeed. assert buildLog.text.contains( 
'[WARNING] Rule 0: org.apache.maven.plugins.enforcer.BannedDependencies failed 
with message:' )
       |        |    |
       |        |    false
       |        Exception in thread "main" 
java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : 
Unsupported major.minor version 51.0
       |                at java.lang.ClassLoader.defineClass1(Native Method)
       |                at 
java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
       |                at 
java.lang.ClassLoader.defineClass(ClassLoader.java:615)
       |                at 
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
       |                at 
java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
       |                at 
java.net.URLClassLoader.access$000(URLClassLoader.java:58)
       |                at 
java.net.URLClassLoader$1.run(URLClassLoader.java:197)
       |                at java.security.AccessController.doPrivileged(Native 
Method)
       |                at 
java.net.URLClassLoader.findClass(URLClassLoader.java:190)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClassFromSelf(ClassRealm.java:401)
       |                at 
org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:42)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadClass(ClassRealm.java:271)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:254)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:239)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.getMainClass(Launcher.java:144)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:266)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
       |        Running post-build script: 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/banned-dependencies-versionrange-fail/verify.groovy>
       
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/banned-dependencies-versionrange-fail/build.log>
[INFO] Building: ban-transitive-dependencies/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/ban-transitive-dependencies/build.log>
 for details.
[INFO] Building: require-active-profile-from-settings/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-active-profile-from-settings/build.log>
 for details.
[INFO] Building: require-snapshot-version_failure/pom.xml
[INFO] ..SUCCESS (0.2 s)
[INFO] Building: ban-distribution-management-multi-module-except-site/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/ban-distribution-management-multi-module-except-site/build.log>
 for details.
[INFO] Building: require-upper-bound-dependencies-managed_success/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-upper-bound-dependencies-managed_success/build.log>
 for details.
[INFO] Building: always-pass/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/always-pass/build.log>
 for details.
[INFO] Building: 
require-plugin-versions-plugin-with-integration-test-lifecycle/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-plugin-versions-plugin-with-integration-test-lifecycle/build.log>
 for details.
[INFO] Building: always-fail/pom.xml
[INFO] ..SUCCESS (0.2 s)
[INFO] Building: require-property/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-property/build.log>
 for details.
[INFO] Building: ban-pom-dependency-version/pom.xml
[INFO] run script verify.groovy
[INFO] ..FAILED (0.2 s)
[INFO]   The post-build script did not succeed. assert buildLog.text.contains( 
'[WARNING] Rule 0: 
org.apache.maven.plugins.enforcer.BanDuplicatePomDependencyVersions failed with 
message:' )
       |        |    |
       |        |    false
       |        Exception in thread "main" 
java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : 
Unsupported major.minor version 51.0
       |                at java.lang.ClassLoader.defineClass1(Native Method)
       |                at 
java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
       |                at 
java.lang.ClassLoader.defineClass(ClassLoader.java:615)
       |                at 
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
       |                at 
java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
       |                at 
java.net.URLClassLoader.access$000(URLClassLoader.java:58)
       |                at 
java.net.URLClassLoader$1.run(URLClassLoader.java:197)
       |                at java.security.AccessController.doPrivileged(Native 
Method)
       |                at 
java.net.URLClassLoader.findClass(URLClassLoader.java:190)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClassFromSelf(ClassRealm.java:401)
       |                at 
org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:42)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadClass(ClassRealm.java:271)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:254)
       |                at 
org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:239)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.getMainClass(Launcher.java:144)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:266)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
       |                at 
org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
       |        Running post-build script: 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/ban-pom-dependency-version/verify.groovy>
       
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/ban-pom-dependency-version/build.log>
[INFO] Building: require-plugin-versions-projectGAVexpressions/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-plugin-versions-projectGAVexpressions/build.log>
 for details.
[INFO] Building: banned-dependencies/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/banned-dependencies/build.log>
 for details.
[INFO] Building: banned-dependencies-wildcards/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/banned-dependencies-wildcards/build.log>
 for details.
[INFO] Building: banned-dependencies-versionrange/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/banned-dependencies-versionrange/build.log>
 for details.
[INFO] Building: require-java-version/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-java-version/build.log>
 for details.
[INFO] Building: require-files-exist/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-files-exist/build.log>
 for details.
[INFO] Building: require-plugin-versions/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/require-plugin-versions/build.log>
 for details.
[INFO] Building: multimodule/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/multimodule/build.log>
 for details.
[INFO] Building: resolve_collect_dependencies/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See 
<https://builds.apache.org/job/maven-enforcer-m3.1.x/org.apache.maven.plugins$maven-enforcer-plugin/ws/target/it/resolve_collect_dependencies/build.log>
 for details.
[INFO] -------------------------------------------------
[INFO] Build Summary:
[INFO]   Passed: 6, Failed: 46, Errors: 0, Skipped: 0
[INFO] -------------------------------------------------
[ERROR] The following builds failed:
[ERROR] *  require-files-size/pom.xml
[ERROR] *  require-upper-bound-dependencies-unique_success/pom.xml
[ERROR] *  builds_a_pom_noop/pom.xml
[ERROR] *  require-no-repositories/pom.xml
[ERROR] *  always-fail-warn/pom.xml
[ERROR] *  evaluate-beanshell/pom.xml
[ERROR] *  require-active-profile-all/pom.xml
[ERROR] *  ban-distribution-management-multi-module-build/pom.xml
[ERROR] *  require-release-version/pom.xml
[ERROR] *  require-snapshot-version_success/pom.xml
[ERROR] *  require-release-dependencies/pom.xml
[ERROR] *  require-plugin-versions-custom-packaging/pom.xml
[ERROR] *  require-upper-bound-dependencies-managed_failure/pom.xml
[ERROR] *  require-plugin-versions-expressions/pom.xml
[ERROR] *  require-plugin-versions-plugin-with-extensions/pom.xml
[ERROR] *  require-no-repositories_failure/pom.xml
[ERROR] *  require-upper-bound-deps_failure/pom.xml
[ERROR] *  ban-distribution-management/pom.xml
[ERROR] *  require-files-dont-exist/pom.xml
[ERROR] *  require-same-versions_success/pom.xml
[ERROR] *  require-active-profile/pom.xml
[ERROR] *  ban-transitive-dependencies-fail/pom.xml
[ERROR] *  require-maven-version/pom.xml
[ERROR] *  require-upper-bound-dependencies-unique_failure/pom.xml
[ERROR] *  require-upper-bound-deps_success/pom.xml
[ERROR] *  require-release-dependencies-excludes/pom.xml
[ERROR] *  dependencies_converge/pom.xml
[ERROR] *  banned-plugins/pom.xml
[ERROR] *  banned-dependencies-versionrange-fail/pom.xml
[ERROR] *  ban-transitive-dependencies/pom.xml
[ERROR] *  require-active-profile-from-settings/pom.xml
[ERROR] *  ban-distribution-management-multi-module-except-site/pom.xml
[ERROR] *  require-upper-bound-dependencies-managed_success/pom.xml
[ERROR] *  always-pass/pom.xml
[ERROR] *  
require-plugin-versions-plugin-with-integration-test-lifecycle/pom.xml
[ERROR] *  require-property/pom.xml
[ERROR] *  ban-pom-dependency-version/pom.xml
[ERROR] *  require-plugin-versions-projectGAVexpressions/pom.xml
[ERROR] *  banned-dependencies/pom.xml
[ERROR] *  banned-dependencies-wildcards/pom.xml
[ERROR] *  banned-dependencies-versionrange/pom.xml
[ERROR] *  require-java-version/pom.xml
[ERROR] *  require-files-exist/pom.xml
[ERROR] *  require-plugin-versions/pom.xml
[ERROR] *  multimodule/pom.xml
[ERROR] *  resolve_collect_dependencies/pom.xml
[INFO] -------------------------------------------------

Reply via email to