[ 
https://issues.apache.org/jira/browse/OFBIZ-6300?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Michael Brohl closed OFBIZ-6300.
--------------------------------
       Resolution: Fixed
    Fix Version/s: Release Branch 14.12

The change is now backported to
release 14.12 r1761502


> Compiler-Error with JDK 1.8 and source compatibility 1.8
> --------------------------------------------------------
>
>                 Key: OFBIZ-6300
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-6300
>             Project: OFBiz
>          Issue Type: Bug
>          Components: framework
>    Affects Versions: Trunk
>            Reporter: Martin Becker
>            Assignee: Michael Brohl
>             Fix For: Release Branch 14.12, 15.12.01
>
>         Attachments: OFBIZ-6300-EntityFieldMap.patch
>
>
> I just found another error compiling the code with JDK 1.8 with source code 
> compatibility switched to 1.8 in my eclipse workspace. The external ant build 
> is working because there is java version 1.7 defined as target in the 
> macros.xml.
> The error is an issue regarding generics in EntityFieldMap.java.
> I will provide a patch her soon.
> The code is the same in the release branches.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to