[ 
https://issues.apache.org/jira/browse/OFBIZ-10694?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16710331#comment-16710331
 ] 

Mathieu Lirzin commented on OFBIZ-10694:
----------------------------------------

Hello Jacques,

This report is the same as OFBIZ-10693. :)

> Generating Asciidoc documentation fails
> ---------------------------------------
>
>                 Key: OFBIZ-10694
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-10694
>             Project: OFBiz
>          Issue Type: Bug
>          Components: ALL COMPONENTS
>    Affects Versions: Trunk
>            Reporter: Jacques Le Roux
>            Priority: Major
>         Attachments: OFBIZ-10694.patch
>
>
> When trying tasks generateOfbizDocumentation or 
> generateAllPluginsDocumentation I get
> {code:java}
> C:\projectsASF\ofbiz>gradlew generateOfbizDocumentation
> > Task :generateOfbizDocumentation FAILED
>  Exception in thread "main" java.lang.ExceptionInInitializerError
>  at org.codehaus.groovy.runtime.InvokerHelper.<clinit>(InvokerHelper.java:86)
>  at 
> groovy.lang.GroovyObjectSupport.getDefaultMetaClass(GroovyObjectSupport.java:59)
>  at groovy.lang.GroovyObjectSupport.<init>(GroovyObjectSupport.java:32)
>  at groovy.lang.Reference.<init>(Reference.java:38)
>  at 
> org.asciidoctor.gradle.backported.AsciidoctorJavaExec.main(AsciidoctorJavaExec.groovy:188)
>  Caused by: groovy.lang.GroovyRuntimeException: Conflicting module versions. 
> Module [groovy-all is loaded in version 2.5.4 and you are trying to load 
> version 2.4.7
>  at 
> org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl$DefaultModuleListener.onModule(MetaClassRegistryImpl.java:523)
>  at 
> org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanExtensionModuleFromProperties(ExtensionModuleScanner.java:87)
>  at 
> org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanExtensionModuleFromMetaInf(ExtensionModuleScanner.java:81)
>  at 
> org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanClasspathModulesFrom(ExtensionModuleScanner.java:63)
>  at 
> org.codehaus.groovy.runtime.m12n.ExtensionModuleScanner.scanClasspathModules(ExtensionModuleScanner.java:55)
>  at 
> org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl.<init>(MetaClassRegistryImpl.java:124)
>  at 
> org.codehaus.groovy.runtime.metaclass.MetaClassRegistryImpl.<init>(MetaClassRegistryImpl.java:85)
>  at groovy.lang.GroovySystem.<clinit>(GroovySystem.java:36)
>  ... 5 more
> {code}
> [Some|https://github.com/gradle/gradle/issues/3698] suggest to
> bq. "add configurations.all { exclude module: 'groovy-all' } to the 
> buildscript closure"
> It works but it's a workaround, so this Jira just to remember that it's 
> temporary.
> I guess it's reated to updating to Gradle 5. Should I commit?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to