[ 
https://issues.apache.org/jira/browse/OFBIZ-10826?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16788556#comment-16788556
 ] 

Deepak Dixit edited comment on OFBIZ-10826 at 3/9/19 7:22 AM:
--------------------------------------------------------------

Upgraded Apache poi version from 3.14 to 3.17 at R16.11 as well at r#1855095

[CVE-2017-12626|https://www.cvedetails.com/cve/CVE-2017-12626]
Apache POI in versions prior to release 3.17 are vulnerable to Denial of 
Service Attacks: 1) Infinite Loops while parsing crafted WMF, EMF, MSG and 
macros (POI bugs 61338 and 61294), and 2) Out of Memory Exceptions while 
parsing crafted DOC, PPT and XLS (POI bugs 52372 and 61295).


was (Author: deepak.dixit):
Upgraded Apache poi version from 3.14 to 3.17 at R16.11 as well.

[CVE-2017-12626|https://www.cvedetails.com/cve/CVE-2017-12626]
Apache POI in versions prior to release 3.17 are vulnerable to Denial of 
Service Attacks: 1) Infinite Loops while parsing crafted WMF, EMF, MSG and 
macros (POI bugs 61338 and 61294), and 2) Out of Memory Exceptions while 
parsing crafted DOC, PPT and XLS (POI bugs 52372 and 61295).

> Upgrade Apache Tika to 1.20 (CVE-2018-8017/CVE-2018-17197)
> ----------------------------------------------------------
>
>                 Key: OFBIZ-10826
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-10826
>             Project: OFBiz
>          Issue Type: Bug
>    Affects Versions: Trunk, 17.12.01, 16.11.05, 18.12.01
>            Reporter: Deepak Dixit
>            Assignee: Deepak Dixit
>            Priority: Major
>              Labels: backport-needed
>
> Need to upgrade Apache tika to 1.20.
> Here are the several security vulnerabilities reported for Apache Tika 
> https://cve.mitre.org/cgi-bin/cvekey.cgi?keyword=%22Apache%20tika%22



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to