[ 
https://issues.apache.org/jira/browse/OFBIZ-11128?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jacques Le Roux closed OFBIZ-11128.
-----------------------------------
    Resolution: Invalid

I was wrong, surrounding by <entity-engine-xml>  works! 
It's also stated in the page:
bq. These documents all have a root tag of "<entity-engine-xml>".
This was not necessary before, I now know it's needed

> Error when manually loading data in "XML Data Import" using "Import Text"
> -------------------------------------------------------------------------
>
>                 Key: OFBIZ-11128
>                 URL: https://issues.apache.org/jira/browse/OFBIZ-11128
>             Project: OFBiz
>          Issue Type: Bug
>          Components: framework/webtools
>    Affects Versions: Trunk, Release Branch 16.11, Release Branch 17.12, 
> Release Branch 18.12
>            Reporter: Jacques Le Roux
>            Priority: Major
>
> I cross this issue for already some times and while testing OFBIZ-10966 I 
> decided to report it. It' still present once the today OFBIZ-10966 patch is 
> applied. I guess R16 is also concerned.
> I thought only Windows was concerned but I tested today by copying the 1st 
> block of line in AccountingDemoData.xml and stable as trunk demo also fail.
> Reproducing is easy: simply copy a block of lines from a data file either in 
> Eclipse or in another editor.
> The error is
> {{org.xml.sax.SAXParseException: The markup in the document following the 
> root element must be well-formed.}}
> * Importing only the 1st line works.
> * Removing the lines delimiter (ie have the text not separated by lines) in 
> the OFBiz textarea does not work
> * Converting CR/LF to LF does not help
> * Removing heading or trailing white spaces does not help
> * Surrounding by <entity-engine-xml>  does not help
> In other words you have to import lines one by one.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to