He-Pin commented on issue #3131: URL: https://github.com/apache/pekko/issues/3131#issuecomment-4771325629
Closing due to factual errors in the description: 1. **`Flow.lazyFlow` and `Flow.lazyFutureFlow` already exist** (scaladsl `Flow.scala:726,754`, javadsl `Flow.scala:302,333`). These accept `() => Flow[...]` and `() => Future[Flow[...]]` factories respectively. 2. **`Sink.lazyInit` does not exist** — the correct operator names are `Sink.lazySink` and `Sink.lazyFutureSink`. The core idea — a flow factory driven by the first element (`(firstElement: T) => Future[Flow[T, U, M]]`) — is genuinely distinct from existing `lazyFutureFlow` (which takes a no-arg factory). If this capability is needed, please open a new issue that: - Acknowledges the existing `lazyFlow`/`lazyFutureFlow` operators - Uses correct operator names (`Sink.lazySink`, not `Sink.lazyInit`) - Follows Pekko naming conventions (e.g., `Flow.lazyFutureFlowWith` rather than `lazyInitAsync`) - Justifies the first-element-driven variant vs. using `lazyFutureFlow` with external state or `prefixAndTail(1).flatMapConcat(...)` -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected] --------------------------------------------------------------------- To unsubscribe, e-mail: [email protected] For additional commands, e-mail: [email protected]
