codeant-ai-for-open-source[bot] commented on code in PR #45383:
URL: https://github.com/apache/superset/pull/45383#discussion_r4297210592


##########
requirements/development.in:
##########
@@ -61,3 +61,8 @@ 
testcontainers[cockroachdb,cratedb,mongodb,mssql,mysql,oracle,postgres,trino]>=4
 # raises `zope.interface.exceptions.InvalidInterface` outright on 3.13.
 # 7.2 is the first release with explicit handling for it.
 zope.interface>=7.2
+
+# Security: fonttools (via matplotlib) < 4.62.0 evaluates TTX XML values with
+# eval() in cffLib parseBlendList(), allowing arbitrary code execution from a
+# crafted TTX file (fonttools/fonttools#4039, fixed in 4.62.0 by #4040).
+fonttools>=4.62.0,<5.0.0

Review Comment:
   **Suggestion:** This floor applies only to development installs; 
`apache-superset[prophet]` can still resolve vulnerable `fonttools` through 
Prophet's `matplotlib` dependency.
   
   **Assessment:** ๐ŸŸ  `Major` ยท ๐Ÿ” `Occurrence: Rarely` ยท ๐Ÿท๏ธ `Security`
   
   [![Use CodeAnt 
Skill](https://new-codeant-butcket.s3.us-west-1.amazonaws.com/badges/use-codeant-skill-flat-v2.svg)](https://docs.codeant.ai/cli/resolve-pr-comments-skill)
 [![Fix in 
Cursor](https://new-codeant-butcket.s3.us-west-1.amazonaws.com/badges/fix-in-cursor-flat.svg)](https://app.codeant.ai/fix-in-ide?tool=cursor&prompt_id=b0c733c127b84fe0a1a9f1c4f0f9f805&service=github&base_url=https%3A%2F%2Fgithub.com&org=apache&repo=apache%2Fsuperset)
 [![Fix in VSCode 
Claude](https://new-codeant-butcket.s3.us-west-1.amazonaws.com/badges/fix-in-vscode-claude-flat.svg)](https://app.codeant.ai/fix-in-ide?tool=vscode-claude&prompt_id=b0c733c127b84fe0a1a9f1c4f0f9f805&service=github&base_url=https%3A%2F%2Fgithub.com&org=apache&repo=apache%2Fsuperset)
   <details>
   <summary><b>Prompt for AI Agent ๐Ÿค– </b></summary>
   
   ```mdx
   This is a comment left during a code review.
   
   **Path:** requirements/development.in
   **Line:** 68:68
   **Comment:**
        *Security: This floor applies only to development installs; 
`apache-superset[prophet]` can still resolve vulnerable `fonttools` through 
Prophet's `matplotlib` dependency.
   
   Validate the correctness of the flagged issue. If correct, How can I resolve 
this? If you propose a fix, implement it and please make it concise.
   Once fix is implemented, also check other comments on the same PR, and ask 
user if the user wants to fix the rest of the comments as well. if said yes, 
then fetch all the comments validate the correctness and implement a minimal fix
   ```
   </details>
   <a 
href='https://app.codeant.ai/feedback?pr_url=https%3A%2F%2Fgithub.com%2Fapache%2Fsuperset%2Fpull%2F45383&comment_hash=094d5cd91aa5005db19e2d8bd7b336825c3f97ac1d1cf9084fd00ecf64f1fbec&reaction=like'>๐Ÿ‘</a>
 | <a 
href='https://app.codeant.ai/feedback?pr_url=https%3A%2F%2Fgithub.com%2Fapache%2Fsuperset%2Fpull%2F45383&comment_hash=094d5cd91aa5005db19e2d8bd7b336825c3f97ac1d1cf9084fd00ecf64f1fbec&reaction=dislike'>๐Ÿ‘Ž</a>



-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]


---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to