alberttwong opened a new issue, #45637: URL: https://github.com/apache/superset/issues/45637
### Dependency compatibility gap Superset's `duckdb` extra still excludes DuckDB 2.0, including on current `master`. This also affects the `motherduck` extra because it delegates to `apache-superset[duckdb]`. Verified on 2026-10-22: | Superset source | Declared DuckDB requirement | | --- | --- | | Published 6.1.0 package metadata | `duckdb>=1.4.2,<2` | | `master` at `7fceb05c1ce99424a0832605e5f36276a34cfcf9` | `duckdb>=1.5.5,<2` | | Current DuckDB release on PyPI | `2.0.0` | Sources: [Superset 6.1.0 metadata](https://pypi.org/pypi/apache-superset/6.1.0/json), [pinned master dependency declaration](https://github.com/apache/superset/blob/7fceb05c1ce99424a0832605e5f36276a34cfcf9/pyproject.toml#L178), [MotherDuck alias](https://github.com/apache/superset/blob/7fceb05c1ce99424a0832605e5f36276a34cfcf9/pyproject.toml#L243-L244), and [DuckDB 2.0.0](https://pypi.org/project/duckdb/2.0.0/). The declared ranges have no intersection with `duckdb==2.0.0`. Consequently, an environment requesting Superset's DuckDB extra and DuckDB 2.0 cannot satisfy both requirements. This matters for downstream integrations moving their DuckDB workflows to 2.0 while retaining Superset. ### Requested work Please track a tested DuckDB 2.0 migration, or document the specific compatibility blocker that requires the current ceiling: - Validate the supported `duckdb-engine` version against DuckDB 2.0 and Superset's supported SQLAlchemy version. - Test database connection, schema/table/column reflection, SQL Lab queries, and dataset/chart queries, including date/time, decimal and null result handling. - Update the extra's upper bound, generated dependency files where applicable, and installation documentation once those checks pass; cover the `motherduck` alias too. - If 2.0 must remain excluded, record the blocking upstream issue and supported version guidance here. ### Scope of verification This is a dependency maintenance/compatibility tracking request. The evidence above is package metadata and source inspection; it does not establish runtime compatibility with DuckDB 2.0 or a security vulnerability in the currently supported 1.x line. The requested change should include compatibility tests rather than only removing the upper bound. I searched existing Superset issues and open PRs for DuckDB upgrades and did not find an open 2.0 migration tracker. Related pandas and SQLAlchemy upgrades already have separate PRs (#45325 and #45411), so this report is limited to DuckDB. -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected] --------------------------------------------------------------------- To unsubscribe, e-mail: [email protected] For additional commands, e-mail: [email protected]
