rusackas commented on code in PR #45383:
URL: https://github.com/apache/superset/pull/45383#discussion_r4385252155


##########
requirements/development.in:
##########
@@ -61,3 +61,8 @@ 
testcontainers[cockroachdb,cratedb,mongodb,mssql,mysql,oracle,postgres,trino]>=4
 # raises `zope.interface.exceptions.InvalidInterface` outright on 3.13.
 # 7.2 is the first release with explicit handling for it.
 zope.interface>=7.2
+
+# Security: fonttools (via matplotlib) < 4.62.0 evaluates TTX XML values with
+# eval() in cffLib parseBlendList(), allowing arbitrary code execution from a
+# crafted TTX file (fonttools/fonttools#4039, fixed in 4.62.0 by #4040).
+fonttools>=4.62.0,<5.0.0

Review Comment:
   Same answer as on the fastmcp-side CVE floors: this is a gap in how 
`prophet` (and every other optional extra) is packaged, not something this PR 
owes us. None of the ~50 extras in `pyproject.toml` carry their own security 
floor, so `apache-superset[prophet]` installed straight from PyPI has never 
been protected by anything in this repo. Worth a follow-up issue on extras 
getting their own floors in general, but not a blocker here.



-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]


---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to