sadpandajoe commented on code in PR #45183:
URL: https://github.com/apache/superset/pull/45183#discussion_r4402009492
##########
.github/actions/setup-backend/action.yml:
##########
@@ -24,7 +24,7 @@ runs:
INPUT_PYTHON_VERSION: ${{ inputs.python-version }}
run: |
if [ "$INPUT_PYTHON_VERSION" = "current" ]; then
- RESOLVED_VERSION="3.11"
+ RESOLVED_VERSION="3.12"
Review Comment:
With `current` on 3.12 and `next` on 3.13, no backend unit or integration
job runs on 3.11, but `requires-python` is still `>=3.11` and the `py311` image
is still published. A 3.12-only construct such as `itertools.batched` would
pass CI and then fail for anyone on the supported 3.11 floor. Is there a job
that still runs the backend suite on 3.11, or should one be kept in the matrix?
##########
.github/actions/setup-backend/action.yml:
##########
@@ -24,7 +24,7 @@ runs:
INPUT_PYTHON_VERSION: ${{ inputs.python-version }}
run: |
if [ "$INPUT_PYTHON_VERSION" = "current" ]; then
- RESOLVED_VERSION="3.11"
+ RESOLVED_VERSION="3.12"
Review Comment:
`scripts/uv-pip-compile.sh` reads this `current` value to pick the Python it
resolves `requirements/*.txt` with, so moving it to 3.12 changes what the lock
files should contain. `requirements/development.txt:76` still pins
`backports-tarfile`, which `jaraco-context` only requires on Python < 3.12, so
regenerating on 3.12 drops that pin and the `check-python-deps` job will see a
diff. Should the regenerated requirements files be committed in this PR?
--
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
To unsubscribe, e-mail: [email protected]
For queries about this service, please contact Infrastructure at:
[email protected]
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]