This series refactors and cleans up insert, improves error handling and
reporting, and adds post-insert hook. I intend to add documentation and
more tests, but the code is ready for review. Also, at least some of the
cleanups and fixes in the beginning of the series could go in without
additional tests or documentation.


Jani Nikula (11):
  lib: actually return failures from
  cli/insert: rename check_folder_name to is_valid_folder_name
  cli/insert: move add_file_to_database to a better place
  cli/insert: rename file copy function
  cli/insert: clean up sync_dir
  cli/insert: use a single recursive mkdir function
  cli/insert: abstract temporary filename generation
  cli/insert: rehash file writing functions
  cli/insert: add fail path to add_file_to_database
  cli/insert: require succesful message indexing for success status
  cli/insert: add post-insert hook

 lib/      |    2 +-
 notmuch-insert.c    |  462 +++++++++++++++++++++++++++++----------------------
 test/ |    2 +-
 3 files changed, 262 insertions(+), 204 deletions(-)


notmuch mailing list

Reply via email to