On Wed, 9 Dec 2009 14:24:46 +0100, Ruben Pollan <meskio at sindominio.net> wrote: > Do you like to call them regress? Should I change that?
I don't love the name, (since it's so close to the word "regression" which has a totally different meaning in software context). But I also don't have an immediate suggestion for an improved name yet either. > What about the functions notmuch_*_is_first? Is kind of reversed logic than > notmuch_*_has_more, the last are true when is not reach the limit but the > first ones are true when the limit is reached. But I think it make sense like > that. I'd like a more symmetric API here. Anyone have a favorite set of names for iterating a list in two directions? -Carl -------------- next part -------------- A non-text attachment was scrubbed... Name: not available Type: application/pgp-signature Size: 189 bytes Desc: not available URL: <http://notmuchmail.org/pipermail/notmuch/attachments/20091209/2de7312c/attachment.pgp>