Some (all?) versions of git-buildpackage default to not using
pristine-tar.

Most recently, i stumbled into this trying to build a
stretch-backports package, which was rejected because the orig.tar.gz
did not match.

Stating this clearly in debian/gbp.conf would have avoided this
problem for me.
---
 debian/gbp.conf | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/debian/gbp.conf b/debian/gbp.conf
index 6cb451a4..38aac14d 100644
--- a/debian/gbp.conf
+++ b/debian/gbp.conf
@@ -15,3 +15,6 @@ upstream-tag = %(version)s
 
 # Format for the debian tag
 debian-tag = debian/%(version)s
+
+# use pristine-tar:
+pristine-tar = True
-- 
2.15.1

_______________________________________________
notmuch mailing list
notmuch@notmuchmail.org
https://notmuchmail.org/mailman/listinfo/notmuch

Reply via email to