Daniel Kahn Gillmor <d...@fifthhorseman.net> writes:

> GMime 3.0 and higher can extract session keys, but it will *not*
> extract session keys if it was built with --disable-crypto, or if it
> was built against GPGME version < 1.8.0.
>
> Notmuch currently expects to be able to extract session keys, and
> tests will fail if it is not possible, so we ensure that this is the
> case during ./configure time.
>
> Part of this feels awkward because notmuch doesn't directly depend on
> gpg at all.  Rather, it depends on GMime, and the current
> implementation of GMime depends on GPGME for its crypto, and GPGME in
> turn depends on gpg.
>
> So the use of gpg in ./configure isn't actually introducing a new
> dependency, though if a future version of GMime were ever to move away
> from GnuPG, we might need to reconsider.
>
> Note that this changeset depends on
> id:20190506174327.13457-1-...@fifthhorseman.net , which supplies the
> rfc822 message test/corpora/crypto/basic-encrypted.eml used in it.
>

I pushed this, and broke travis. Can you please have a look at

  https://travis-ci.org/notmuch/notmuch/builds/534979532

d
_______________________________________________
notmuch mailing list
notmuch@notmuchmail.org
https://notmuchmail.org/mailman/listinfo/notmuch

Reply via email to