On Mon 2019-03-18 15:10:51 +0100, Tarvi Verro wrote:
> Method is not supported in Ruby's Mail 2.8.0+.
> ---
>  vim/notmuch.vim | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/vim/notmuch.vim b/vim/notmuch.vim
> index ad8b7c80..541698cd 100644
> --- a/vim/notmuch.vim
> +++ b/vim/notmuch.vim
> @@ -666,7 +666,7 @@ ruby << EOF
>                               date = Time.at(e.newest_date).strftime(date_fmt)
>                               subject = e.messages.first['subject']
>                               if $mail_installed
> -                                     subject = Mail::Field.new("Subject: " + 
> subject).to_s
> +                                     subject = Mail::Field.parse("Subject: " 
> + subject).to_s
>                               else
>                                       subject = 
> subject.force_encoding('utf-8')
>                               end
> -- 

I see this patch is marked "notmuch::moreinfo", but i don't see any
request for more info specifically, so i thought i'd fill that in here.

I don't know vim or ruby, but i would expect a patch like this to
contain at least a pointer to Ruby's Mail package's documentation about
a backward-incompatible change introduced in a certain version, if not
documentation about the expected upgrade path.  Can you provide those
pointers?

Thanks for offering fixes to the notmuch-vim codebase!

              --dkg

Attachment: signature.asc
Description: PGP signature

_______________________________________________
notmuch mailing list
notmuch@notmuchmail.org
https://notmuchmail.org/mailman/listinfo/notmuch

Reply via email to