On Tue 26 May 2020 at 00:41 +0300, Tomi Ollila wrote:

> On Mon, May 25 2020, Floris Bruynooghe wrote:
>
>> In tox.ini the earliest version is 3.5 and if memory serves me right
>> there's a reasonably good reason for that.  I think the notmuch2
>> bindings use some features not yet present in 3.4.  But anything >= 3.5
>> should be supported and if not a bug.  I guess tox.ini should be updated
>> with 3.8 sometime :)
>
> I've been long thinking whether our current python3 check is "strict"
> enough, as it, in configure, is:
>
> if "$python" -c 'import sys; assert sys.version_info >= (3,0)' > /dev/null 
> 2>&1
>
> Perhaps that should be updated to (3,5) ?

If this check is only used to decide to build the python-cffi/notmuch2
bindings, then yes.
_______________________________________________
notmuch mailing list
notmuch@notmuchmail.org
https://notmuchmail.org/mailman/listinfo/notmuch

Reply via email to