Take explicit dependency to plexus-utils in a newer version to override the 
built-in dependency to plexus-utils 1.1 in MVN < 3 (improves cmd-line handling)
-----------------------------------------------------------------------------------------------------------------------------------------------------------

                 Key: NPANDAY-417
                 URL: https://issues.apache.org/jira/browse/NPANDAY-417
             Project: NPanday
          Issue Type: Improvement
          Components: Maven Plugins
    Affects Versions: 1.3.1-incubating
            Reporter: Lars Corneliussen
            Assignee: Lars Corneliussen
             Fix For: 1.3.1-incubating


>From Maven 2.0.6 Maven automatically injected plexus-utils:1.1 as a direct 
>dependency to any Maven plugin.

So even if there was a transitive dependency to a higher version (in our case 
the executable-component needs at least 1.4.5), that got overruled by the 
automagically injected 1.1.

Related issues from Maven:
* http://jira.codehaus.org/browse/MNG-3819
* http://jira.codehaus.org/browse/MNG-4276
* http://jira.codehaus.org/browse/MNG-2892

This lead to NPANDAY-416, where we had trouble with the quoting of commandline 
parameters.

The solution is to add a direct dependency to a newer plexus-utils-version 
(specified in plugins-parent) into all our plugins.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to