Eric Kolotyluk created NPANDAY-615:
--------------------------------------

             Summary: Can't Build Library
                 Key: NPANDAY-615
                 URL: https://issues.apache.org/jira/browse/NPANDAY-615
             Project: NPanday
          Issue Type: Bug
          Components: Maven Plugins
    Affects Versions: 1.5.0-incubating
         Environment: Apache Maven 3.1.1 
(0728685237757ffbf44136acec0402957f723d9a; 2013-09-17 08:22:22-0700)
Maven home: D:\bin\Apache\apache-maven-3.1.1
Java version: 1.7.0_51, vendor: Oracle Corporation
Java home: C:\Program Files\Java\jdk1.7.0_51\jre
Default locale: en_US, platform encoding: utf-8
OS name: "windows 8", version: "6.2", arch: "amd64", family: "windows"
            Reporter: Eric Kolotyluk


When I use the following in my pom.xml

  <groupId>net.kolotyluk.windows.elevate</groupId>
  <artifactId>elevate-common</artifactId>
  <version>0.0.21-SNAPSHOT</version>
  <packaging>dotnet-module</packaging>

I get

[INFO] Scanning for projects...
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]
[ERROR]   The project 
net.kolotyluk.windows.elevate:elevate-common:0.0.21-SNAPSHOT 
(D:\Users\Eric\Software\Project\Repositories\csharp-windows-elevate\elevate-common\pom.xml)
 has 1 error
[ERROR]     Unknown packaging: dotnet-library @ line 19, column 14

Maybe this is a documentation problem, but I cannot figure out from the 
documentation any way to correctly build a library. 

Using



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to