Hello all,

I am using ns-allinone-2.28 on cygwin (win XP). I have installed the
FHMIP Extension follow the steps in "Handover Blackout Duration of
Layer 3 Mobility Management Schemes" from
http://tagus.inesc-id.pt/~pestrela/ns2/mobility.html, and I recompiled
ns2 by running "make". When I tried to run the script in the
extension, I got the famous error: Wrong Node Routing Agent. I thought
there may be something wrong with the installation of NOAH, so I check
them again.But the problem is still.

I also change the ns-lib.tcl file as below:

switch -exact $routingAgent_ {

 default {
   puts "Wrong node routing agent!: $routingAgent_"

 I recompiled again, but there was still the same error without any
routing agent name following. I am really puzzled why the change in
ns-lib.tcl not affect the error, even though I recompiled ns2 without
any error?

I found there are many issue about this error, please let me know how
you solved the problem.

Any ideas will be appreciated.

Thank you!


Reply via email to