From: Tamer [mailto:[EMAIL PROTECTED] 
Sent: 25 December 2007 21:10
To: 'ns-users@ISI.EDU'
Subject: how to solve this error with the Directed Diffusion please???


Dear NS-Users,


I am doing a project on the routing protocols in Wireless Sensor Networks.
Actually I implemented the DSR, DSDV and AODV and they worked well. But,
when I use the Directed Diffusion one, and after I did the following:


set opt(adhocRouting)   Directed_Diffusion


and did the following in the node configuration :


$ns_ node-config -adhocRouting $opt(adhocRouting) \

             -llType $opt(ll) \

             -diffusionFilter $opt(filters)


When I run the tcl script it gives me the following:


[EMAIL PROTECTED] ~/ns-allinone-2.29/ns-2.29/tcl/ex

$ ns diffusion25.tcl

Seeding Random number generator with 1.0


num_nodes is set 50

invalid command name "-macType"

    while executing

"-macType $opt(mac) \

                 -ifqType $opt(ifq) \

                 -ifqLen $opt(ifqlen) \

                 -antType $opt(ant) \

                 -propType $opt(prop) \

                 -phyType $opt(netif) \


    (file "diffusion25.tcl" line 212)


So, how to solve this problem plzzzzz. Could anybody help please?


Thanks in Advance,


Thamer Al-Jahamneh

Reply via email to