Hello everyone,

I am working on WSNs.

I found only the mannasim 29 version and I am not sure it may be installed
on ns-2.34.

When trying to install mannasim, I followed these instructions:

Step 1. Get MannaSim Framework tar.gz file.(
Step 2. Unpack the tar.gz file into ns-2.29 main. Inside mannasim/ folder
created look for a ns-modified-files/ folder where ns-2.29 modified
files are stored.
Step 3. Substitue ns-2.29 files listed below by it’s MannaSim version stored
ns-modified-files/ folder in mannasim/ directory.
       * ns-2.29/apps/udp.cc
       * ns-2.29/common/ns-process.h
       * ns-2.29/common/packet.cc
       * ns-2.29/common/packet.h
       * ns-2.29/mac/mac-802_11.cc
       * ns-2.29/tcl/lib/ns-lib.tcl
       * ns-2.29/tcl/lib/ns-default.tcl
       * ns-2.29/Makefile.in
Step 4. In ns-2.34 main folder re-run configuration script and then
re-compile the system:

However, when I tried ./make ,in the ns main folder, the following message
was displayed;

 bash: ./make: No such file or directory

So there is no "make" file in the folder. I tried  the 'make" command to
recompile but I had;

make: Warning: File `ns' has modification time 8.9e+07 s in the future
make: *** No rule to make target `tcp/tcp-qs.o', needed by `ns'.  Stop.

`tcp/tcp-qs.o', does not even exist in the mentioned directory!

Thank you!

Reply via email to