Hi Aslinda,

Thanks for your comments. BTW, how do you uninstall/install gcc 4.3? Do
you have any suggestion of website which gives instruction?

Lupe,

Aslinda gave a very good comment on gcc version. BTW, I just post a note
on how to install NS2 on Ubuntu. Please see the following post.

Problem:
http://www.ns2ultimate.com/post/439346614/working-combination-ns-2-34-ubuntu-8-04-and-perhaps

Solution:
http://www.ns2ultimate.com/post/425358640/ns2-windows-7-and-cygwin-1-7-what-a-nightmare

Best Regards,

Teerawat Issariyakul
http://www.ns2ultimate.com/
http://www.facebook.com/pages/Teerawat-Issariyakul/358240861417
http://twitter.com/T_Bear
http://www.t-issariyakul.blogspot.com
http://www.ece.ubc.ca/~teerawat






On 3/10/2010, "Aslinda Hassan" <aslinda.has...@mun.ca> wrote:

>Hi..
>
>Just to add, I have successfully install ns-2.34 in ubuntu 9.10.  But you
>are right about the gcc distribution, since ubuntu 9.10 uses gcc-4.4.  When
>I used the default version of gcc in ubuntu 9.10, I did encounter some
>problems. So, I downloaded gcc-4.3 and changed the gcc compiler in the
>makefile.in.  Once I did that, everything went well.  
>
>
>Regards
>
>Aslinda Hassan
>Computer Engineering Research Lab
>Faculty of Engineering and Applied Science
>Memorial University of Newfoundland
>
>
>
>> -----Original Message-----
>> From: ns-users-boun...@isi.edu [mailto:ns-users-boun...@isi.edu] On
>> Behalf Of Teerawat Issariyakul
>> Sent: Wednesday, March 10, 2010 4:31 AM
>> To: ssdo...@gmail.com; ns-users@ISI.EDU; lupe...@yahoo.com
>> Subject: Re: [ns] ns-2.34 installation problem
>> 
>> 
>> 
>> Hi Sidney,
>> 
>> Thank you for your email. I have tried the followings and all of them
>> does not work.
>> 
>> - Window XP, Cygwin 1.7, ns-2.33
>> - Window XP, Cygwin 1.5, ns-2.33
>> - Window XP, Cygwin 1.7, ns-2.34
>> - Window XP, Cygwin 1.5, ns-2.34
>> 
>> - Window 7, Cygwin 1.7, ns-2.33
>> - Window 7, Cygwin 1.7, ns-2.34
>> - I guess the other version won't work too.
>> 
>> - Ubuntu 9.10, ns-2.33
>> - Ubuntu 9.10, ns-2.34
>> 
>> I am guessing that the problem is with recent change in gcc package of
>> all Linux distribution.
>> 
>> The one that work is Ubuntu 8.04 with ns-2.34.
>> 
>> Lupe, you might want to try the same thing.
>> 
>> What I do is that I set up a Ubuntu box inside a VMware running on
>> Windows 7. It's a bit of hassle but it works.
>> 
>> I will put the instruction up on my blog soon.
>> 
>> Best Regards,
>> Teerawat Issariyakul
>> http://www.ns2ultimate.com/
>> http://www.ece.ubc.ca/~teerawat
>> http://www.t-issariyakul.blogspot.com
>> 
>> 
>> 
>> 
>> On 3/8/2010, "Sidney Doria" <ssdo...@gmail.com> wrote:
>> 
>> >Issariayakul,
>> >
>> >this problem has been reported by me and is already addressed by Tom
>> >in NS-2.35 RC, as you can see in the NS-2 roadmap:
>> >
>> >http://nsnam.isi.edu/nsnam/index.php/Roadmap
>> >
>> >You can use NS-2.33, NS-2.34 in Cygwin 1.5.25 (legacy-setup.exe), but
>> >to install It in Windows 7, you must use "compatible mode (as win95)".
>> >After the setup, recreate the icon in start menu (the original icon
>> >won't work), or use the cygwin.bat directly.
>> >
>> >
>> >Sidney Doria
>> >UFCG / BRAZIL
>> >
>> >2010/3/6 Teerawat Issariyakul <teera...@ece.ubc.ca>:
>> >>
>> >>
>> >> Hi Lupe,
>> >>
>> >> I am facing the similar problem. Both Ns 2.33 and NS 2.34 do not
>> work
>> >> with Cygwin 1.7. The suggestion is to go back and use Cygwin 1.5.
>> >>
>> >> As for you problem--an alert for gcc is not found, I guess you can
>> ignore
>> >> it by pressing 'n'. GCC is on your system but NS2 just can't find
>> it.
>> >> You can begin building it.
>> >>
>> >> The real problem, (according to my guess), is you cannot build
>> Tcl/Tk on
>> >> Cygwin 1.7. I am trying several options. I would like to share it
>> with
>> >> you. Please see below:
>> >>
>> >> 1. Cygwin 1.7 does not work for both 2.33 and 2.34.
>> >> 2. Cygwin 1.5 MAY work with 2.33 and 2.34. I tried it long ago. And,
>> it
>> >> worked. The problem is I cannot find Cygwin 1.5 anywhere. I try to
>> use
>> >> setup-legacy.exe from Cygwin. But I have a feeling that it still
>> install
>> >> Cygwin v 1.7.
>> >> 3. Cygwin 1.5 does not work with Windows 7. Even if you get it to
>> work,
>> >> you cannot run it on Windows 7.
>> >>
>> >> Here is my main question: Where do you get Cygwin 1.5.25.
>> >>
>> >> Thanks,
>> >> Best Regards,
>> >> Teerawat Issariyakul
>> >> http://www.ns2ultimate.com/
>> >> http://www.ece.ubc.ca/~teerawat
>> >> http://www.t-issariyakul.blogspot.com
>> >>
>> >>
>> >> On 3/5/2010, "Lupe Krops" <lupe...@yahoo.com> wrote:
>> >>
>> >>>
>> >>>Hi to everyone,
>> >>>
>> >>>
>> >>>I'm trying to install ns-allinone-2.34 on win xp.
>> >>>I have installed the full package of cygwin v. 1.7.1.
>> >>>When I tried to ./install the ns-2.34 it gave me the message
>> >>>the "Package gcc is not present on your system" (also cannot
>> >>>find xorg-x11-base and xfree86-base). I found a post
>> >>>saying that ns-2.34 best works with cygwin 1.5.25, so i removed
>> >>>the previous version of cygwin and installed v. 1.5.25.
>> >>>However, it gives me the same errors.
>> >>>I checked with gcc -v command and shows me that it runs gcc version
>> 3.4.4
>> >>>Also i compiled (without any problem) a .c file, just to see that
>> the compiler is
>> >>>successfully installed.
>> >>>
>> >>>I really don't know what else to do or what to check.
>> >>>Any help is much appreciated.
>> >>>
>> >>>Regards,
>> >>>Lup
>> >>>
>> >>>
>> >>>
>> >>>
>> >>
>> >>
>> >
>> >
>> >
>> >--
>> >Sidney Doria
>> >Redes ad hoc móveis
>> >Doutorado em Computação
>> >UFCG
>> >Brasil
>> >
>> >"Nessa jornada, o conhecimento será o seu escudo..."
>> >(Mestre dos Magos no episódio do grimoire de ouro)
>> >
>
>

Reply via email to