Hi all.
I am getting this error on running my .tcl file for a newly created
protocol.
  (_o17 cmd line 1)
    invoked from within
"_o17 cmd target _o21"
    invoked from within
"catch "$self cmd $args" ret"
    invoked from within
"if [catch "$self cmd $args" ret] {
set cls [$self info class]
global errorInfo
set savedInfo $errorInfo
error "error when calling class $cls: $args" $..."
    (procedure "_o17" line 2)
    (SplitObject unknown line 2)
    invoked from within
"$agent target [$self set ll_(0)]"
    (procedure "_o14" line 66)
    (Node/MobileNode add-target-rtagent line 66)
    invoked from within
"$self add-target-rtagent $agent $port"
    (procedure "_o14" line 28)
    (Node/MobileNode add-target line 28)
    invoked from within
"$self add-target $agent $port"
    (procedure "_o14" line 15)
    (Node attach line 15)
    invoked from within
"$node attach $ragent [Node set rtagent_port_]"
    (procedure "_o3" line 84)
    (Simulator create-wireless-node line 84)
    invoked from within
"_o3 create-wireless-node"
    ("eval" body line 1)
    invoked from within
"eval $self create-wireless-node $args"
    (procedure "_o3" line 23)
    (Simulator node line 23)
    invoked from within
"$ns node"
    ("for" body line 2)
    invoked from within
"for {set i 0} {$i < $val(nn) } {incr i} {
                set node_($i) [$ns node]
                $node_($i) random-motion 0              ;# disable random motion
        }"
    (file "simulation.tcl" line 66)

Does the line "_o17 cmd target _o21" suggest that the function target is not
defined? If so, then in which file should I define the instproc target?

Also how should I rectify the other errors?

Regards,
The Learner

-- 
View this message in context: 
http://old.nabble.com/Error-while-running-the-tcl-script---target_-...----tp28232938p28232938.html
Sent from the ns-users mailing list archive at Nabble.com.

Reply via email to