TO the NS-USERS community,

Although i believe that i will get a reply even after so many attempts in
posting these questions to the NS users Community and still not getting any
help.Also after knowing that their are so many experienced Ns-users in this
mailing list who have at some point in time successfully implemented
LEACH,but still no one would come forward to help or even give a hint.


I have lost all hope and most probably will have to look into other research
areas maybe altogether  stop using NS-2 for my WSN simulations even after
spending so much of my time on it.


If any of the users stumbled upon the same problem or know a possible
solution plz look into this as this is my last cry for any help or guidance
to this forum.



I am trying to implement leach on NS-2.29 using mannasim and for quite a
long time i am stuck with this problem.

The following error occures while running leach on Mannasim.


It would be of great help if anybody knows any other way and has
successfully implemented LEACH on NS2(any version) using any other
alternatives available.

 <----------------->

[r...@localhost bin]# ./ns leach.tcl

Initializing MannaSim Script...

Setting up mica 2 mote with Antenna/OmniAntenna and range = 100



Nodes count:

 - 1 access points

 - 10 common nodes

 - 0 cluster heads

 - 11 nodes

 - DumbAgent routing protocol

 - LL link layer

 - Phy/WirelessPhy network interface





Scenario size: 100.0 x 100.0





Using trace.tr as trace file

num_nodes is set 11

Creating an access point...

Setting up mica 2 mote with Antenna/OmniAntenna and range = 100

Using mica 2 mote settings

Setting up mica 2 mote with Antenna/OmniAntenna and range = 100

warning: Please use -channel as shown in tcl/ex/wireless-mitf.tcl

INITIALIZE THE LIST xListHead

* Access point 0 = 0 created in (43.509210899243698, 34.247529848593999,
0.0)

Creating common node...

Setting up mica 2 mote with Antenna/OmniAntenna and range = 100

Using mica 2 mote settings

Setting up mica 2 mote with Antenna/OmniAntenna and range = 100

Setting disseminating type to programmed

Setting disseminating interval: 20.0

* Node 1 = 1 created in (91.818819237788588, 58.541928026146216, 0.0)

NO CLUSTER HEADS HAS BEEN DEFINED! Assuming 20% of common nodes.

* Node 2 = 2 created in (49.756124825103264, 65.884154646603463, 0.0)

* Node 3 = 3 created in (70.132374749580578, 15.679780308008093, 0.0)

* Node 4 = 4 created in (85.40044733574635, 38.361567695793497, 0.0)

* Node 5 = 5 created in (80.309079112628979, 58.697910308231563, 0.0)

* Node 6 = 6 created in (97.07222320003072, 66.915544060485217, 0.0)

* Node 7 = 7 created in (20.387572013022179, 87.62193810549654, 0.0)

* Node 8 = 8 created in (93.201789163612659, 22.833003859423567, 0.0)

* Node 9 = 9 created in (49.502869578778217, 51.503630704946644, 0.0)

* Node 10 = 10 created in (4.5511585215810495, 9.5448948021721538, 0.0)

Starting Simulation...

Segmentation fault

<----------------->


This occurs when the tcl file is generated by the script generator tool.



Yours Sincerely

Aakash

Reply via email to