I checked it with 100, 200, 300, 400, 500, 1000 kbps, no issue.

--

Best Regards,

Imran Khan

Research Engineer

Network and Service Architecture Lab

Institute Telecom, Telecom SudParis, CNRS Lab UMR5157

9 rue Charles Fourier, 91011 Evry, France


+33 (0) 6 10 91 00 63
http://www.about.me/imrankhan1984



On Tue, Jul 5, 2011 at 2:31 PM, Inès Doghri <ines.dog...@gmail.com> wrote:

> Thank you for your message and your help...
> I check your tcl file and I see that the disactivation of RTS/CTS works
> well with the 20kb/s rate of CBR. When I put for example the CBR rate at
> 100kb/s the simulation doesn't work perfectly and we get the Event UID
> error.
> I let you try with a bigger CBR rate such as 100kb/s et tell me about your
> results please...
>
> Thanks,
> Ines
> +
>
>
>
> On Tue, Jul 5, 2011 at 1:58 PM, Imran khan <imrankhan1...@gmail.com>wrote:
>
>> I just re-checked this command and its working perfectly. I did not get
>> the Event UID error. Without the command the RTS/CTS packets are in the
>> trace file, but when I use the RTSThreshold command there are no RTS/CTS
>> packets. I'm sending you the files I used for testing, may be you'll get the
>> idea, one is the tcl and other contains the movement patterns of 30nodes for
>> 300seconds.
>>
>>
>> One thing I can advise is to use the RTSThreshold command before creating
>> new instance of simulator, above this line 'set ns_ [new Simulator]' ans use
>> a debugger to correctly find the source of error.
>>
>> --
>>
>> Best Regards,
>>
>> Imran Khan
>>
>> Research Engineer
>>
>> Network and Service Architecture Lab
>>
>> Institute Telecom, Telecom SudParis, CNRS Lab UMR5157
>>
>> 9 rue Charles Fourier, 91011 Evry, France
>>
>>
>> +33 (0) 6 10 91 00 63
>> http://www.about.me/imrankhan1984
>>
>>
>>
>> On Tue, Jul 5, 2011 at 2:43 AM, Inès Doghri <ines.dog...@gmail.com>wrote:
>>
>>> Hi,
>>>
>>> At the beginning, the simulation works well but in the middle of
>>> simulation it stops and generates an error : "Scheduler: Event UID not
>>> valid!".
>>> Do you have disactivated RTS/CTS mode with succes under OLSR protocol, if
>>> yes could you please tell me how do you do this and which version of OLSR
>>> did you have used in your simulation?
>>>
>>>
>>> Thanks in advance,
>>> Ines
>>>
>>>
>>> On Tue, Jul 5, 2011 at 11:27 AM, Imran khan <imrankhan1...@gmail.com>wrote:
>>>
>>>> Hi,
>>>>
>>>> It should work, did get an error? how did you find that its not working?
>>>>
>>>> --
>>>>
>>>> Best Regards,
>>>>
>>>> Imran Khan
>>>>
>>>> Research Engineer
>>>>
>>>> Network and Service Architecture Lab
>>>>
>>>> Institute Telecom, Telecom SudParis, CNRS Lab UMR5157
>>>>
>>>> 9 rue Charles Fourier, 91011 Evry, France
>>>>
>>>>
>>>> +33 (0) 6 10 91 00 63
>>>> http://www.about.me/imrankhan1984
>>>>
>>>>
>>>>
>>>> On Tue, Jul 5, 2011 at 10:42 AM, Inès Doghri <ines.dog...@gmail.com>wrote:
>>>>
>>>>>
>>>>> Hello,
>>>>> I'm using this version of OLSR
>>>>> http://masimum.dif.um.es/?Software:UM-OLSR:Installation and it is
>>>>> working
>>>>> ....
>>>>>
>>>>> But I can't disable the RTS/CTS mode with a simple add in the tcl
>>>>> script of
>>>>> the following command "MAC/802_11 set RTSThreshold_ 3000" ....
>>>>> It will be very helpful if someone can tell me how I can disable
>>>>> RTS/CTS
>>>>> mode under OLSR protocol simulation.
>>>>> Thanks in advance,
>>>>> Ines
>>>>>
>>>>>
>>>>> On Tue, Jul 5, 2011 at 8:53 AM, fat computer <fatma...@yahoo.com>
>>>>> wrote:
>>>>>
>>>>> > can u send to me umolsr , because I use file in link
>>>>> > http://masimum.dif.um.es/?Software:UM-OLSR:Installation I don't know
>>>>> if it
>>>>> > is work or not, can u send an example to test OLSR.
>>>>> >
>>>>> > Thanx
>>>>> > fatcomp
>>>>> >
>>>>> >
>>>>> > ----- Original Message -----
>>>>> > From: Inès Doghri <ines.dog...@gmail.com>
>>>>> > To: ns-users@ISI.EDU
>>>>> > Cc:
>>>>> > Sent: Wednesday, June 29, 2011 7:16 PM
>>>>> > Subject: [ns] ns2.29: Disable RTS/CTS in OLSR
>>>>> >
>>>>> >
>>>>> > Dear Ns users,
>>>>> >
>>>>> > I simulate OLSR (umolsr version) routing protocol  under ns 2.29 and
>>>>> I want
>>>>> > to disable RTS/CTS mode. To do so, I add in my tcl script the
>>>>> following
>>>>> > command "MAC/802_11 set RTSThreshold_ 3000" and it generates an error
>>>>> when
>>>>> > simulating the tcl script : "Scheduler: Event UID not valid!".
>>>>> > I would understand why this and how can I disable RTS/CTS with OLSR.
>>>>> >
>>>>> > thanks in advance,
>>>>> > best regards Ines
>>>>> >
>>>>> >
>>>>> >
>>>>> >
>>>>> > --
>>>>> > Ines DOGHRI
>>>>> >
>>>>> >
>>>>> >
>>>>> > --
>>>>> > Ines DOGHRI
>>>>> >
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Ines DOGHRI
>>>>>
>>>>
>>>>
>>>
>>>
>>> --
>>> Ines DOGHRI
>>>
>>
>>
>
>
> --
> Ines DOGHRI
>

Reply via email to