Public bug reported:

no matter what I put into parameters, when I click on Test Mail settings
(under report tab) nssbackup-config-gui locks up and I have to kill it.

$ sudo nssbackup-config-gui 
2009-04-06 00:22:08,202 - INFO - ConfigManager.py:__init__(300) - ConfigManager 
created with default values. Config file set to '/etc/nssbackup.conf'.
2009-04-06 00:22:08,207 - INFO - ConfigManager.py:__init__(300) - ConfigManager 
created with default values. Config file set to '/etc/nssbackup.conf'.

(nssbackup-config-gui:8183): libglade-WARNING **: could not look up stock id 
'Profile Manager'
/usr/lib/python2.5/site-packages/nssbackup/ui/GladeGnomeApp.py:74: GtkWarning: 
gtk_tree_model_get_n_columns: assertion `GTK_IS_TREE_MODEL (tree_model)' failed
  self.xml = gtk.glade.XML(fname,domain='nssbackup')
/usr/lib/python2.5/site-packages/nssbackup/ui/GladeGnomeApp.py:74: GtkWarning: 
gtk_combo_box_set_column_span_column: assertion `column_span >= -1 && 
column_span < col' failed
  self.xml = gtk.glade.XML(fname,domain='nssbackup')
/usr/lib/python2.5/site-packages/nssbackup/ui/GladeGnomeApp.py:74: GtkWarning: 
GtkSpinButton: setting an adjustment with non-zero page size is deprecated
  self.xml = gtk.glade.XML(fname,domain='nssbackup')
2009-04-06 00:22:09,052 - WARNING - ConfigManager.py:getSchedule(621) - Config 
file doesn't have schedule infos, probing from filesystem 
2009-04-06 00:22:09,054 - WARNING - ConfigManager.py:getSchedule(621) - Config 
file doesn't have schedule infos, probing from filesystem 
^CTraceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/nssbackup/ui/SBConfigGTK.py", line 
1467, in on_testMailButton_clicked
    result = self.configman.testMail()
  File "/usr/lib/python2.5/site-packages/nssbackup/managers/ConfigManager.py", 
line 862, in testMail
    server.connect(self.get("report","smtpserver"), 
self.get("report","smtpport"))
  File "/usr/lib/python2.5/smtplib.py", line 301, in connect
    self.sock.connect(sa)
  File "<string>", line 1, in connect
KeyboardInterrupt
nssbackup-config-gui: Fatal IO error 2 (No such file or directory) on X server 
:0.0.


I am using the Hardy Version (on debian, so that might be the problem). I am 
using version 2 RC7. it's installed from the PPA.

** Affects: nssbackup
     Importance: Undecided
         Status: New

-- 
Test Mail Settings causes hang
https://bugs.launchpad.net/bugs/356032
You received this bug notification because you are a member of NSsbackup
team, which is subscribed to NSsbackup.

_______________________________________________
Mailing list: https://launchpad.net/~nssbackup-team
Post to     : nssbackup-team@lists.launchpad.net
Unsubscribe : https://launchpad.net/~nssbackup-team
More help   : https://help.launchpad.net/ListHelp

Reply via email to