Hallo Adam,


Adam Lindsay <[EMAIL PROTECTED]> wrote:

 ...which I copied to the working directory. It should be included in
 gwTeX.

 Running the command above should do it.

 > $ pltotf HelveticaNeue
 > pltotf: HelveticaNeue.pl: No such file or directory

 The fatal error above didn't generate a .pl file, so the next command
 wasn't able to use it.

 > As I have never used afm2pl or pltotf the usage above is praobably
 > wrong.
 > Or was my Fontforge export bad?
 >
 > And looking at your test file: where are your ttf and other files in
 > this situation?
 >
 All in the working directory. I could then rename, put them in the
 tex/fonts/ tree, and rehash, but that's it down to the essence.

 Here's another goodie:


...


Now it works. Very nice and clear ways to get it. But both goodies don't work with OSX's Helvetica.dfont

If you try it with the .ttf you'll get:

Error: pdfetex (file Helvetica.ttf): can't find table `OS/2'
 ==> Fatal error occurred, the output PDF file is not finished!


And if instead you use the .pfb then you'll get the misplaced macrons and tildes that I've reported.

Just try this:

\loadmapline[+Helvetica Helvetica " TeXnANSIEncoding
ReEncodeFont " <texnansi.enc <Helvetica.pfb]
\starttext
\definedfont[Helvetica]
TAVAT.Po
T{}A{}V{}A{}T{}.{}P{}o

\showfont[Helvetica] R\d{o} R{\=o} R\~o
\page\showcharacters
\stoptext


I know the HelveticaNeue is more beautiful ... but nevertheless it would be interesting why there is the above error (and how it can be solved).



Thanks for your help and support!

Steffen
_______________________________________________
ntg-context mailing list
ntg-context@ntg.nl
http://www.ntg.nl/mailman/listinfo/ntg-context

Reply via email to