Did you try \input{file.tex} ?
(Just an idea, didn’t try.)


Am 29.05.22 um 18:34 schrieb Joel via ntg-context:
After a recent update to ConTeXt, the code no longer seems to allow me to \input a file within a table:

         \NC {\bf Term} \NC {\bf Definition} \NC\NR
        \input test2.tex %<----here you see I have input a file inside the table

File test2.tex contains "\NC {\bf Term} \NC {\bf Definition} \NC\NR".

I also tried defining a macro earlier in the document...

     \NC \NC \NC\NR
     \NC #1 \NC #2 \NC\NR

...then placing that in test2.tex, e.g.:

\tablewordis{my word}{my definition}

I get the error: " The file ended when scanning an argument."

Before the update, this code worked fine.

How can I \input a file while inside a table environment, as above?

I have a document that has 100s of these inputs in my code, and now nothing will compile.


If your question is of interest to others as well, please add an entry to the 

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki     : http://contextgarden.net

Reply via email to