Hi Mohamed,

On Mon, 8 Dec 2008, Mohamed Bana wrote:

Hi Aditya,

Thanks for getting back to me.

I did a fresh checkout and tried to compile, I uncommented out these lines from the beginning of macros.tex.

L3 \setupcolors[state=start]
...
L16 \setupcite  [interaction=start, compress=no,color=] %darkgreen]


L276-278 in env-thesis.tex

\setupinteraction[state=start,style=,color=]
\setupinteraction[focus=standard]


It's still the same;


I followed the same steps. Downloaded the files from http://www.eecs.umich.edu/~adityam/publications/thesis/thesis.tar.gz

unzipped them, removed t-bib.tex from the current directory, made the changes indicated by you above, and did "context thesis". Everything compiles files (there is one warning about Delicious-Bold.otf).

Version:

ConTeXt  ver: 2008.11.30 14:39 MKIV  fmt: 2008.12.1  int: english/english

And have you seen this error;

! LuaTeX error ...nimals/tex/texmf-local/tex/context/base/core-syn.lua:71: attempt to call field 'process' (a nil value)
stack traceback:
...nimals/tex/texmf-local/tex/context/base/core-syn.lua:71: in function 'process' ...nimals/tex/texmf-local/tex/context/base/core-syn.lua:125: in function 'process'
        <main ctx instance>:1: in main chunk.
\mkloadsortedlist ...xlua {joblists.process('#1')}
\getvalue {\s!reset #1}\eg...
\doplacelistofsynonyms ... ]\mkloadsortedlist {#1}
\endgroup \ifutilitydone \...
l.162 \placelistofabbreviations

An error like this usually means that luatex or mtxrun is old.

I am using context version version: 2008.11.10 21:40 (hmmm... that is after a fresh update from the minimals, which is strange) and LuaTeX, Version snapshot-0.31.0-2008120715.

I do not know if something broke in a newer version of context, but for that I will first need to figure out why my minimals are not being updated.

Since I was at it, I redid the local change in t-bib so that I can have citations of different colors. Also changed a few other macros, to work well with colors (I had stopped playing with colors a while back ...). I am uploading the changed files and the typeset pdf file at

http://pantheon.yale.edu/~am894/temp/

Try to download and compile this and see if it works. In the mean time I will investigate why minimals aren't being updated on my machine.

Aditya
___________________________________________________________________________________
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : https://foundry.supelec.fr/projects/contextrev/
wiki     : http://contextgarden.net
___________________________________________________________________________________

Reply via email to