On Oct 20, 2009, at 3:52 PM, Hans Hagen wrote:

in lxml-ent.lua ...

function xml.resolved_entity(str)
   local e = xml.entities[str]
   if e then
       local te = type(e)
       if te == "function" then
           e(str)
       elseif e then
           texsprint(ctxcatcodes,e)
       end
   else
texsprint(ctxcatcodes,"\\xmle{",str,"}{",utfupper(str),"}") -- we need to use our own upper
   end
end


Thank you Hans, but that's not yet the solution. I still get the same error. I thought it might be related to the fact that I had the entity &hfill; in my titles, but even after removing it, I still get the error.



there has been quite some changes in the xml machinery; what exactly do you do with entities?


Well, I just map a few special characters and commands to entities. In my environment, I have

\setupxml[entities=mkii]

and then stuff like this:

\defineXMLentity[smallspace]{\,}
\defineXMLentity[percent]{\percent}
\defineXMLentity[onequarter]{\onequarter}
\defineXMLentity[threequarter]{\threequarter}
\defineXMLentity[onehalf]{\onehalf}
\defineXMLentity[textellipsis]{\textellipsis}
\defineXMLentity[nbsp]{~}
\defineXMLentity[hfill]{\hfill}

Is there a different way for doing this now?

All best

Thomas
___________________________________________________________________________________
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki     : http://contextgarden.net
___________________________________________________________________________________

Reply via email to