On Wed, Jan 20, 2010 at 2:59 PM, Wolfgang Schuster <
schuster.wolfg...@googlemail.com> wrote:

>  Am 20.01.10 08:58, schrieb Marius:
>
> Hello all,
>
> I add my questions regarding simplefonts to this thread too.
> How to enable em dash and en dash? It looks like I need to set tlig to
> yes, but with heading pasted below, the --- is not interpreted as em
> dash.
>
>
> %%%%%%%%%%%%%%%%
> \usemodule[simplefonts]
> \setmainfont[Times New Roman][script=latin, texligatures=yes]
>
>  \setmainfont[Times New Roman][mode=node]
>
> It's a problem with the font as you can see in this example:
>
>  \definefontfeature[default][default][mode=node] % mode=base works
>
> \definefont[times][name:timesnewroman*default]
>
>
>  \starttext
>
> \times text---text
>
> \stoptext
>

I realy do not understand what these \definexxx commands mean, but  then I
set \setmainfont[Times New Roman][mode=base], I get em dash as expected,
thank you.

>  \setsansfont[Arial Unicode MS]
> \setmonofont[Courier New]
>
> \setupbodyfont[10pt]
>
>  Can you use the module options to change the font size.
>
> \usemodule[simplefonts][size=10pt]
>
> or
>
> \setupsimplefonts[size=10pt]
>

Why? It works as expected with \setupbodyfont[10pt] too.
___________________________________________________________________________________
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki     : http://contextgarden.net
___________________________________________________________________________________

Reply via email to