Hi all,

today i tried to update context and also updated first-setup.sh and now i get 
in terminal:

Bernhards-MacBook-Pro:ConTeXt Bernhard$ rsync -av 
rsync://contextgarden.net/minimals/setup/first-setup.sh .
receiving file list ... done

sent 37 bytes  received 91 bytes  256.00 bytes/sec
total size is 3573  speedup is 27.91
Bernhards-MacBook-Pro:ConTeXt Bernhard$ . /Applications/ConTeXt/first-setup.sh 
receiving file list ... done

sent 37 bytes  received 132 bytes  112.67 bytes/sec
total size is 5363753  speedup is 31738.18
/Applications/ConTeXt/bin/mtxrun:1932: bad argument #1 to 'osgetenv' (string 
expected, got boolean)

When you want to use context, you need to initialize the tree by typing:

  . /Applications/ConTeXt/tex/setuptex

in your shell or add
to PATH variable if you want to set it permanently.
This can usually be done in .bashrc, .bash_profile
(or whatever file is used to initialize your shell).

i don´t know where the problem lies (obviously mtxrun is complaining). 
the last update i did worked normal (ConTeXt  ver: 2010.05.24 13:05 MKIV  fmt: 
Please help!

best regards

If your question is of interest to others as well, please add an entry to the 

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki     : http://contextgarden.net

Reply via email to