Hello,

I have a problem to \input a file [in the same directory as the main file is].

This problem started appearing with the latest minimals (updated today evening) 
and there was no such a problem before.

Try this:

--- main.mkiv

\enableregime[cp1250]

\input{_inc.mkiv}

\starttext
  AAA
\stoptext

---

--- _inc.mkiv

INC.MKIV

---

And the the compilation error:

---

D:\Lukas\ConTeXt\Samples\t-Inc>set 
PATH=c:\ConTeXt\tex\texmf-mswin\bin;C:\WINDOWS\System32\Wbem;C:\WINDOWS/system32;C:\WINDOWS;D:/Programs/Tcl/bin;C:/gs/gs8.54/bin;C:/Program
 Files/Common Files/Autodesk Shared/;c:/Program Files/Microsoft SQL Server/90/Tool
s/binn/;C:\Program Files\Lua\5.1;C:\Program 
Files\Lua\5.1\clibs;C:\adabas\bin;C:\adabas\pgm;D:\Lukas\Bat;D:\Programs.Con;C:\Program
 Files\Gtk+\bin;;C:\PROGRA~1\COMMON~1\AUTODE~1

D:\Lukas\ConTeXt\Samples\t-Inc>context.exe main.mkiv

MTXrun | run 1: luatex 
--fmt="c:/ConTeXt/tex/texmf-cache/luatex-cache/context/f53042fa2e1c106bc7e3383ec8c3a00c/formats/cont-en"
 
--lua="c:/ConTeXt/tex/texmf-cache/luatex-cache/context/f53042fa2e1c106bc7e3383ec8c3a00c/formats/cont-en.lui"
 --backend=pdf "./ma
in.mkiv"This is LuaTeX, Version beta-0.64.0-2010111223 (rev 3956)
 \write18 enabled.
(main.mkiv

ConTeXt  ver: 2010.11.27 14:27 MKIV  fmt: 2010.11.28  int: english/english

system          : cont-new loaded
(c:/ConTeXt/tex/texmf-context/tex/context/base/cont-new.tex
systems         : beware: some patches loaded from cont-new.tex
(c:/ConTeXt/tex/texmf-context/tex/context/base/cont-new.mkiv))
system          : cont-fil.mkiv loaded
(c:/ConTeXt/tex/texmf-context/tex/context/base/cont-fil.mkiv
loading         : ConTeXt File Synonyms
)
system          : cont-sys.rme loaded
(c:/ConTeXt/tex/texmf-context/tex/context/user/cont-sys.rme 
(c:/ConTeXt/tex/texmf-context/tex/context/base/type-def.mkiv) 
(c:/ConTeXt/tex/texmf-context/tex/context/base/type-lua.mkiv) 
(c:/ConTeXt/tex/texmf-context/tex/context/base/type-siz.mkiv) (c:/ConTeX
t/tex/texmf-context/tex/context/base/type-otf.mkiv))
system          : cont-err loaded
(c:/ConTeXt/tex/texmf-context/tex/context/base/cont-err.tex
systems         : no file 'cont-sys.tex', using 'cont-sys.rme' instead
)
system          : main.top loaded
(main.top){c:/ConTeXt/tex/texmf/fonts/map/dvips/lm/lm-math.map}{c:/ConTeXt/tex/texmf/fonts/map/dvips/lm/lm-rm.map}{c:/ConTeXt/tex/texmf-context/fonts/map/pdftex/context/mkiv-base.map}
bodyfont        : 12pt rm is loaded
fonts           : preloading latin modern fonts (first stage)
language        : language en is active
! LuaTeX error ...TeXt/tex/texmf-context/tex/context/base/regi-ini.lua:100: 
attempt to call global 'translate' (a nil value).
<insert>

l.3 \input{_inc.mkiv}

?
! Emergenc^Cy stop.
<
insD:\Lukas\ConTeXt\Samples\t-Inc>ert>

l.3 \input{_inc.mkiv}

!  ==> Fatal error occurred, no output PDF file produced!

D:\Lukas\ConTeXt\Samples\t-Inc>
---

Bug anywhere?

Friendly regards,

Lukas

Attachment: _inc.mkiv
Description: Binary data

Attachment: main.log
Description: Binary data

Attachment: main.mkiv
Description: Binary data

___________________________________________________________________________________
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki     : http://contextgarden.net
___________________________________________________________________________________

Reply via email to