Hi,

I had problems loading an old ttf font in ConTeXt. When trying to figure
out what goes wrong, I added "--trackers=fonts.all". Sadly this breaks with

[..]
-gds.lua><+ R:/tex/texmf-context/tex/context/base/font-def.lua>
! LuaTeX error R:/tex/texmf-context/tex/context/base/trac-set.lua:87:
attempt to index local 'done' (a nil value)
stack traceback:
        R:/tex/texmf-context/tex/context/base/trac-set.lua:87: in function 'set'
        R:/tex/texmf-context/tex/context/base/trac-set.lua:142: in function 
'fnc'
        R:/tex/texmf-context/tex/context/base/trac-set.lua:152: in function
'register'
        R:/tex/texmf-context/tex/context/base/trac-set.lua:234: in function
'register'
        R:/tex/texmf-context/tex/context/base/font-def.lua:20: in main chunk
        R:/tex/texmf-context/tex/context/base/luat-cod.lua:42: in function
'registercode'
        <main ctx instance>:1: in main chunk.
\registerctxluafile ...ua.registercode("#1","#2")}

l.96 \registerctxluafile{font-def}{1.001}

?
-----------------
Minimal example:

\startext
FOO
\stoptext

and call it with

context --trackers=fonts.all test.tex



Greetings, Peter
___________________________________________________________________________________
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki     : http://contextgarden.net
___________________________________________________________________________________

Reply via email to