Please try the following example:

-- start code --



   [title={A nice book},
    author={Andy Tom},

Hello world!

-- end code --

The firstpage export value (huhn.jpg) is your cover image. Please put huhn.jpg 
or something else in the same directory as your tex file. I named the tex=file 
test_00.tex in my case.

After compiling with the latest context, you can run 'mtxrun --script epub 
--make test_00.specification' to generate the epub file.

Please note two more things: 
(1) The mtx-epub script was broken a couple of days ago. Well not actually 
broken, but somehow an old version sneaked in. If the author names and such do 
not get exported into the epub, this might as well be the case for you. The 
latest one (ver: 2012.11.14 11:37 MKIV  fmt: 2012.11.16) works fine again. 
(2) Calibre and other readers as well as e.g. the ipad have some nasty caching 
feature. In case you change little things and try to reload the same book in 
your reader, it might still show the old one from the cache. I found, that 
deleting the 'old' book first works most of the times.

I just started working on the epub output of my lecture notes again, since 
there were no readers able to output math until 2 weeks ago.

If I find some time later, I will update the epub page in the wiki.

I hope that helps.

On Nov 15, 2012, at 7:58 PM, Bill Meahan wrote:

> I tried to generate an epub document using ConTeXt following the recipe on 
> the wiki. Didn't work. So, I tried running the export-example.tex file that 
> comes with the distribution, unmodified. Same bad results.
>    Cover is not generated
>    TOC is not generated (though it is noted this might be the state of the 
> export)
>    Sectioning doesn't happen.
>    Paragraphing doesn't happen.
>    The resultant epub file cannot even be opened with FBReader.
> Importing the epub into Sigil shows one big blob of text, with only the 
> between word spacing that's present in the source file. The \quotation{} 
> markup did get turned into quotation marks, chapter numbers were generated 
> and the rest of the markup was stripped out.
> Same behavior with both the TeXLive 2012 version of ConTeXt and a quite 
> recent beta.
> Up-to-date Ubuntu 12.04
> Linux Escherton 3.2.0-32-generic #51-Ubuntu SMP Wed Sep 26 21:32:50 UTC 2012 
> i686 i686 i386 GNU/Linux
> What am I doing wrong?
> -- 
> Bill Meahan
> Westland, Michigan USA
> ___________________________________________________________________________________
> If your question is of interest to others as well, please add an entry to the 
> Wiki!
> maillist : /
> webpage  : /
> archive  :
> wiki     :
> ___________________________________________________________________________________

If your question is of interest to others as well, please add an entry to the 

maillist : /
webpage  : /
archive  :
wiki     :

Reply via email to