On 07/29/2017 04:45 AM, Gerion Entrup wrote:
> Was not that simple, but I found the problem, that causes it:
> subsubsections without numbers.
> [...]
> Is there a way to fix this?

I would say this may be a bug.

I don’t know how it is implemented, but prefixsegments (or prefixes) for
captions only work when number is enabled.

This makes sense if the section is part of the prefixsegments, but not
if it isn’t.

Another sample that shows the problem:

    \mainlanguage[de]
    \setupexternalfigures[location=default]
    \setuphead[subsection][number=no]
    \setupcaptions[prefixsegments=chapter]
    \setuphead[subsubsection][number=yes]

    \starttext

    \chapter[title=Kapitel]
    \placefigure{Eine Kuh}{\externalfigure[cow.pdf][scale=250]}

    \section[title=Abschnitt]
    \placefigure{Eine Kuh}{\externalfigure[cow.pdf][scale=250]}

    \subsection[title=Hier gibt’s ein Problem]
    \placefigure{Eine Kuh}{\externalfigure[cow.pdf][scale=250]}

    \subsection[title=Und hier gibt’s ein Problem auch]
    \placefigure{Eine Kuh}{\externalfigure[cow.pdf][scale=250]}

    \subsubsection[title=Aber hier gibt’s kein Problem]
    \placefigure{Eine Kuh}{\externalfigure[cow.pdf][scale=250]}
    \stoptext

If this isn’t a bug, the code to avoid the problem is too tricky for me
(and simply far beyond my knowledge).

Excuse my ignorance,

Pablo
-- 
http://www.ousia.tk
___________________________________________________________________________________
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki     : http://contextgarden.net
___________________________________________________________________________________

Reply via email to