On 11/27/2018 05:38, mf wrote:
In my setup, i have an index of names:


The indexing of names can be toggled with a mode: --mode=AddNames

The setup is something like this:


I noticed that \Name[key]{term} adds some space, leading to a different typesetting of the paragraph in rare cases (especially in a paragraph full of names).

Can \Name[key]{term} add some space, or should i look for a different bug in my setup?

Sorry, no MWE; i tried, but i could not reproduce the problem in a minimal example.

This has been a long-standing issue with registers in straight (non-XML) code. I always follow a \index{} with a % to avoid it. I suspect that will help here as well, splitting onto two lines, as


or perhaps


Have you tried this?

(I cannot construct an MWE at this point either.)


If your question is of interest to others as well, please add an entry to the 

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://context.aanhet.net
archive  : https://bitbucket.org/phg/context-mirror/commits/
wiki     : http://contextgarden.net

Reply via email to