On Thu, Apr 10, 2008 at 10:17 AM, Lou Pecora <[EMAIL PROTECTED]> wrote:
>  Yes, I use np= number of points, too.  But you all
>  might want to use something else.  That's the point of
>  the flexibility of import ... as

I would recommend against using np as a variable name.  Variable names
should be short and informative.  I would much rather see something
like "num_points".

>  Trying to lock in namespaces as np or N or whatever is
>  a BAD idea.  Allow the flexibility.  You can admonish
>  against from ... import * for newbies and then tell
>  them to use from ... import actual function names (as
>  mentioned above).  But locking people into a standard,
>  even an informal one is, as someone else said, acting
>  a bit too much like accountants.  Stop, please!

Coding standards and conventions in a large, collaborative codebase
are essential.  If you want to contribute to NumPy or SciPy you will
have to conform to these conventions.  In your own private code or
private project do whatever you want.

-- 
Jarrod Millman
Computational Infrastructure for Research Labs
10 Giannini Hall, UC Berkeley
phone: 510.643.4014
http://cirl.berkeley.edu/
_______________________________________________
Numpy-discussion mailing list
Numpy-discussion@scipy.org
http://projects.scipy.org/mailman/listinfo/numpy-discussion

Reply via email to