2006/2/22, Peter Selinger <[EMAIL PROTECTED]>: > Steve, > > use newhidups, not hidups. You should do either this: > > ./configure --with-drivers=newhidups > make > > (to compile only the newhidups driver - saves a lot of time), or this: > > ./configure > make > make usb > > (to compile all drivers). Note that simply "make" does not compile any > USB drivers by default, which is an outdated behavior and one that we > should probably change. > > Arnaud, what is your feeling about the "make usb" target? Does it > still serve a useful purpose? Also, are there any situations where the > hidups driver is still preferred/needed? Perhaps we should change > drivers.txt to encourage people more strongly to use newhidups.
The merge of the USB target is also part of the NUT Packaging Standard evolution. Only bigger things like make-snmp will remain apart... for 2.0.3, I've already changed the order in drivers.list to "newhidups or hidups" for any units other than MGE. For the trunk, hidups and its reference can now be removed. An entry should be logged in UPGRADING to mention the replacement of hidups by newhidups. And now that we're svn'ed, newhidups can be renamed to usbhid-ups... (don't forget its reference, an UPGRADING / FAQ entry, ...) As for the configure/make, simply adding USB_DRIVER_LIST to DRIVER_BUILD_LIST in drivers/Makefile.in should be sufficient, whatever the detection status of libusb / linux hiddev is (to be validated): if some USB driver(s) can be built, USB_DRIVER_LIST will be non empty. Otherwise, it will contain the buildable USB drivers. The same should be done for man/Makefile.in... Peter: can you take over all that? Arnaud -- Linux / Unix Expert - MGE UPS SYSTEMS - R&D Dpt Network UPS Tools (NUT) Project Leader - http://www.networkupstools.org/ Debian Developer - http://people.debian.org/~aquette/ OpenSource Developer - http://arnaud.quette.free.fr/ _______________________________________________ Nut-upsuser mailing list [email protected] http://lists.alioth.debian.org/mailman/listinfo/nut-upsuser

