Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Nutch Wiki" for change 

The following page has been changed by uygar bayar:

   * If you get errors about "Type mismatch in value from map:" (expected 
ObjectWritable, but received NutchWritable), then you likely are missing the 
two steps I just added in step 9 above.  Sorry about that, I forgot about 
making the change there in SolrIndexer.
  I did everything but i got this error any idea??
  2008-04-03 15:42:28,009 WARN  mapred.LocalJobRunner - job_local_1
@@ -46, +47 @@

          at org.apache.nutch.indexer.SolrIndexer.main(
+ -------------------------------------------------------
+ I changed lines and it worked.But this time gave this error. I tried both 
private and protected scopes but nothing changed.
+ I also changed this line  Document doc = (Document) ((ObjectWritable) 
value).get(); with this  Document doc = (Document) ((NutchWritable) 
value).get(); this time gave build error..
+ 2008-04-04 10:41:48,490 WARN  mapred.LocalJobRunner - job_local_1
+ java.lang.ClassCastException: 
+         at 
+         at org.apache.hadoop.mapred.ReduceTask$2.collect(
+         at org.apache.nutch.indexer.Indexer.reduce(
+         at org.apache.nutch.indexer.Indexer.reduce(
+         at
+         at 
+ 2008-04-04 10:41:49,085 FATAL indexer.Indexer - SolrIndexer: Job failed!
+         at org.apache.hadoop.mapred.JobClient.runJob(
+         at org.apache.nutch.indexer.SolrIndexer.index(
+         at
+         at
+         at org.apache.nutch.indexer.SolrIndexer.main(

Reply via email to