Messages by Thread
-
Re: [PATCH V8 05/10] famfs_fuse: GET_DAXDEV message and daxdev_table
sashiko-bot
-
Re: [PATCH V8 04/10] famfs_fuse: Create files with famfs fmaps
sashiko-bot
-
Re: [PATCH v2 1/5] ACPI: NFIT: validate subtable extents before dispatch
sashiko-bot
-
Re: [PATCH v2 3/5] ACPI: NFIT: validate interleave and flush array extents
sashiko-bot
-
Re: [PATCH v2 4/5] ACPI: NFIT: validate control region extent
sashiko-bot
-
Re: [PATCH v2 2/5] ACPI: NFIT: accept SPA structures with an unused location cookie
sashiko-bot
-
Re: [PATCH v2 5/5] ACPI: NFIT: bound the platform capability mask
sashiko-bot
-
[ndctl PATCH] util/sysfs: do not fail on missing bind attributes
Alison Schofield
-
Re: [PATCH 4/4] mm/mempolicy: enhance weighted interleave with package-aware locality
sashiko-bot
-
Re: [PATCH 3/4] mm/memory-tiers: register CXL nodes to memory packages via initiator
sashiko-bot
-
Re: [PATCH 1/4] mm/numa: introduce nearest_nodes_nodemask()
sashiko-bot
-
Re: [PATCH 2/4] mm/memory-tiers: introduce package-aware topology management for NUMA nodes
sashiko-bot
-
Re: [RFC PATCH v1 2/3] blk-cgroup: store blkcg in bio instead of blkg
sashiko-bot
-
Re: [RFC PATCH v1 1/3] blk-cgroup: add helpers for bio cgroup state
sashiko-bot
-
Re: [RFC PATCH v1 3/3] blk-cgroup: move async bio punt state to blkcg
sashiko-bot
-
Re: [PATCH V12 11/12] famfs: Report device capacity via statfs so df works
sashiko-bot
-
Re: [PATCH V12 02/12] famfs: Module operations, fs_context, and mount
sashiko-bot
-
Re: [PATCH V12 08/12] famfs: iomap_begin and file-to-dax offset resolution
sashiko-bot
-
Re: [PATCH V12 06/12] famfs: Introduce mmap and VM fault handling
sashiko-bot
-
Re: [PATCH V12 01/12] dax: replace exported dax_dev_get() with non-allocating dax_dev_find()
sashiko-bot
-
Re: [PATCH V12 04/12] famfs: Introduce inode_operations and super_operations
sashiko-bot
-
Re: [PATCH V12 10/12] famfs: Add runtime operation-permission (opts) framework
sashiko-bot
-
Re: [PATCH V12 09/12] famfs: Register secondary daxdevs by path (FAMFSIOC_DAXDEV_OPEN)
sashiko-bot
-
Re: [PATCH V12 03/12] famfs: Add daxdev table and dax notify_failure support
sashiko-bot
-
Re: [PATCH V12 05/12] famfs: Introduce file_operations read/write
sashiko-bot
-
Re: [PATCH V12 07/12] famfs: MAP_CREATE ioctl and fmap ingest (ABI 44)
sashiko-bot
-
Re: [PATCH v12 6/8] cxl/mem: Configure dynamic capacity interrupts
sashiko-bot
-
Re: [PATCH v12 3/8] cxl/cdat: Gather DSMAS data for DCD partitions
sashiko-bot
-
Re: [PATCH v12 2/8] cxl/mem: Read dynamic capacity configuration from the device
sashiko-bot
-
Re: [PATCH v12 7/8] cxl/core: Return endpoint decoder information from region search
sashiko-bot
-
[ndctl PATCH 1/2] cxl/list: emit decoder locked status
Alison Schofield
-
Re: [PATCH 1/9] ACPI: use a named initializer for acpi_device_id
sashiko-bot
-
Re: [PATCH 2/9] ACPI: drop unused assignment of acpi_device_id::driver_data
sashiko-bot
-
Re: [PATCH 9/9] ACPI: use a named initializer for acpi_device_id::id
sashiko-bot
-
Re: [PATCH 5/9] ACPI: amba: drop unused assignment of acpi_device_id::driver_data
sashiko-bot
-
Re: [PATCH 3/9] ACPI: pci: drop unused assignment of acpi_device_id::driver_data
sashiko-bot
-
Re: [PATCH 8/9] ACPI: x86: use a named initializer for acpi_device_id::id
sashiko-bot
-
Re: [PATCH 4/9] ACPI: ghes-nvidia: use a named initializer for acpi_device_id::id
sashiko-bot
-
Re: [PATCH 7/9] ACPI: nfit: core: drop unused assignment of acpi_device_id::driver_data
sashiko-bot
-
Re: [PATCH 6/9] ACPI: dptf: drop unused assignment of acpi_device_id::driver_data
sashiko-bot
-
[ndctl PATCH] ndctl.spec.in: make xmlto BuildRequires depend on rhel < 9
Alison Schofield
-
Re: [PATCH] ACPI: NFIT: validate subtable extents before parsing
sashiko-bot
-
Re: [PATCH v5 23/36] mm/mempolicy: apply policy at the kernel zone for private-node binds
sashiko-bot
-
Re: [PATCH v5 29/36] mm: add NODE_PRIVATE_CAP_DEMOTION for private-node tiering demotion
sashiko-bot
-
Re: [PATCH v5 17/36] mm/vmscan: disallow reclaim of private node memory
sashiko-bot
-
Re: [PATCH v5 27/36] mm: add NODE_PRIVATE_CAP_USER_NUMA for userland numa controls
sashiko-bot
-
Re: [PATCH v5 35/36] KVM: guest_memfd: bind backing memory to a NUMA node at creation
sashiko-bot
-
Re: [PATCH v5 06/36] cpuset: exclude private nodes from cpuset.mems (default-open)
sashiko-bot
-
Re: [PATCH v5 22/36] mm/mempolicy: add MPOL_F_PRIVATE and zonelist selection
sashiko-bot
-
Re: [PATCH v5 32/36] mm/khugepaged: base private node collapse eligiblity on actor/cap bits
sashiko-bot
-
Re: [PATCH v5 26/36] mm: add NODE_PRIVATE_CAP_RECLAIM for opted-in private node reclaim
sashiko-bot
-
Re: [PATCH v5 24/36] mm/mempolicy: add in-kernel MPOL_BIND interfaces for drivers/services
sashiko-bot
-
Re: [PATCH v5 14/36] mm/damon: skip private node memory in DAMON migration and pageout
sashiko-bot
-
Re: [PATCH v5 20/36] mm/memcontrol: account private-node memory in per-node stats
sashiko-bot
-
Re: [PATCH v5 19/36] proc: include N_MEMORY_PRIVATE nodes in numa_maps output
sashiko-bot
-
Re: [PATCH v5 04/36] numa: introduce N_MEMORY_PRIVATE
sashiko-bot
-
Re: [PATCH v5 25/36] mm/memory_hotplug: support N_MEMORY_PRIVATE node hotplug
sashiko-bot
-
Re: [PATCH v5 16/36] mm/khugepaged: skip private node folios when trying to collapse.
sashiko-bot
-
Re: [PATCH v5 10/36] mm/madvise: disallow madvise operations on private node folios
sashiko-bot
-
Re: [PATCH v5 09/36] mm/migrate: disallow userland driven migration for private nodes
sashiko-bot
-
Re: [PATCH v5 03/36] mm/page_alloc: let the bulk and folio allocators carry alloc_flags
sashiko-bot
-
Re: [PATCH v5 11/36] mm/compaction: disallow compaction on private nodes
sashiko-bot
-
Re: [PATCH v5 08/36] mm/mempolicy: skip private node folios when queueing for migration
sashiko-bot
-
Re: [PATCH 1/2] libnvdimm: nd.h: clean up kernel-doc warnings
sashiko-bot
-
Re: [PATCH V11 9/9] famfs_fuse: Add documentation
sashiko-bot
-
Re: [PATCH V11 8/9] famfs_fuse: Add DAX address_space_operations with noop_dirty_folio
sashiko-bot
-
Re: [PATCH V11 5/9] famfs_fuse: register fs-dax daxdevs via FUSE_DEV_IOC_DAXDEV_OPEN
sashiko-bot
-
Re: [PATCH V11 7/9] famfs_fuse: fail I/O on invalid or errored daxdevs
sashiko-bot
-
Re: [PATCH V11 4/9] famfs_fuse: Create files with famfs fmaps
sashiko-bot
-
Re: [PATCH V11 6/9] famfs_fuse: Plumb dax iomap and fuse read/write/mmap
sashiko-bot
-
Re: [PATCH V11 2/9] famfs_fuse: Basic fuse kernel ABI enablement for famfs
sashiko-bot
-
Re: [PATCH V11 3/9] famfs_fuse: Plumb the GET_FMAP message/response
sashiko-bot
-
Re: [PATCH v7 07/10] dax/kmem: resolve default online type at probe time
sashiko-bot
-
Re: [PATCH v7 04/10] mm/memory_hotplug: export mhp_get_default_online_type
sashiko-bot
-
Re: [PATCH v7 08/10] dax/kmem: extract hotplug/hotremove helper functions
sashiko-bot
-
Re: [PATCH v7 06/10] mm/memory_hotplug: add offline_and_remove_memory_ranges()
sashiko-bot
-
Re: [PATCH v7 03/10] mm/memory_hotplug: pass online_type to online_memory_block() via arg
sashiko-bot
-
Re: [PATCH v7 01/10] mm/memory: add memory_block_aligned_range() helper
sashiko-bot
-
[PATCH v2 00/33] mm: make VMA page offset handling more consistent
Lorenzo Stoakes
-
[PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
Lorenzo Stoakes
-
Re: [PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
Liam R. Howlett
-
Re: [PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
Zi Yan
-
[PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
Lorenzo Stoakes
-
Re: [PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
Liam R. Howlett
-
Re: [PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
Zi Yan
-
[PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Lorenzo Stoakes
-
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Liam R. Howlett
-
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Lorenzo Stoakes (ARM)
-
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Zi Yan
-
[PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
Lorenzo Stoakes
-
Re: [PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
Zi Yan
-
[PATCH v2 04/33] mm: introduce and use vma_end_pgoff()
Lorenzo Stoakes
-
Re: [PATCH v2 04/33] mm: introduce and use vma_end_pgoff()
Zi Yan
-
[PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
Lorenzo Stoakes
-
Re: [PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
Zi Yan
-
[PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Lorenzo Stoakes
-
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Zi Yan
-
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Lorenzo Stoakes (ARM)
-
[PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
Lorenzo Stoakes
-
Re: [PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
Zi Yan
-
[PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Lorenzo Stoakes
-
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Gregory Price
-
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Zi Yan
-
[PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Lorenzo Stoakes
-
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Gregory Price
-
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Zi Yan
-
[PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Lorenzo Stoakes
-
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Zi Yan
-
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Liam R. Howlett
-
[PATCH v2 19/33] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Lorenzo Stoakes
-
Re: [PATCH v2 19/33] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Vlastimil Babka (SUSE)
-
[PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Lorenzo Stoakes
-
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Lorenzo Stoakes (ARM)
-
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Lorenzo Stoakes (ARM)
-
[PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Lorenzo Stoakes
-
Re: [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Lorenzo Stoakes (ARM)
-
Re: [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Zi Yan
-
[PATCH v2 24/33] mm/vma: move __install_special_mapping() to vma.c
Lorenzo Stoakes
-
Re: [PATCH v2 24/33] mm/vma: move __install_special_mapping() to vma.c
Vlastimil Babka (SUSE)
-
[PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
Lorenzo Stoakes
-
Re: [PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
Zi Yan
-
[PATCH v2 20/33] mm/vma: remove duplicative vma_pgoff_offset() helper
Lorenzo Stoakes
-
Re: [PATCH v2 20/33] mm/vma: remove duplicative vma_pgoff_offset() helper
Vlastimil Babka (SUSE)
-
[PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
Lorenzo Stoakes
-
Re: [PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
Gregory Price
-
Re: [PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
Vlastimil Babka (SUSE)
-
[PATCH v2 15/33] mm/vma: refactor vmg_adjust_set_range() for clarity
Lorenzo Stoakes
-
Re: [PATCH v2 15/33] mm/vma: refactor vmg_adjust_set_range() for clarity
Vlastimil Babka (SUSE)
-
[PATCH v2 27/33] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
Lorenzo Stoakes
-
Re: [PATCH v2 27/33] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
Vlastimil Babka (SUSE)
-
[PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
Lorenzo Stoakes
-
Re: [PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
Gregory Price
-
Re: [PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
Vlastimil Babka (SUSE)
-
[PATCH v2 16/33] mm/vma: minor cleanup of expand_[upwards, downwards]()
Lorenzo Stoakes
-
Re: [PATCH v2 16/33] mm/vma: minor cleanup of expand_[upwards, downwards]()
Vlastimil Babka (SUSE)
-
[PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
Lorenzo Stoakes
-
Re: [PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
Lorenzo Stoakes (ARM)
-
[PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
Lorenzo Stoakes
-
Re: [PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
Gregory Price
-
Re: [PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
Vlastimil Babka (SUSE)
-
[PATCH v2 17/33] mm: introduce and use linear_page_delta()
Lorenzo Stoakes
-
Re: [PATCH v2 17/33] mm: introduce and use linear_page_delta()
Vlastimil Babka (SUSE)
-
[PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Lorenzo Stoakes
-
Re: [PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Lorenzo Stoakes (ARM)
-
[PATCH v2 21/33] mm: use linear_page_[index, delta]() consistently
Lorenzo Stoakes
-
Re: [PATCH v2 21/33] mm: use linear_page_[index, delta]() consistently
Vlastimil Babka (SUSE)
-
[PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Lorenzo Stoakes
-
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Gregory Price
-
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Zi Yan
-
[PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Lorenzo Stoakes
-
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Gregory Price
-
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Lorenzo Stoakes (ARM)
-
[PATCH v2 33/33] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
Lorenzo Stoakes
-
[PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
Lorenzo Stoakes
-
Re: [PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
Gregory Price
-
Re: [PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
Vlastimil Babka (SUSE)
-
[PATCH v2 31/33] mm/vma: use guard clauses in can_vma_merge_[before, after]()
Lorenzo Stoakes
-
Re: [PATCH v2 31/33] mm/vma: use guard clauses in can_vma_merge_[before, after]()
Vlastimil Babka (SUSE)
-
[PATCH v2 32/33] tools/testing/vma: default VMA, mm flag bits to 64-bit
Lorenzo Stoakes
-
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Andrew Morton
-
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Lorenzo Stoakes
-
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Christian König
-
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Lorenzo Stoakes (ARM)
-
[ndctl PATCH] contrib: add Fedora release scripts
Alison Schofield
-
Re: [PATCH] nvdimm: ndtest: remove redundant NULL check before vfree()
sashiko-bot
-
[ndctl PATCH] test/cxl-security.sh: test dimm unlock with a large serial number
Alison Schofield
-
[ndctl PATCH] test/cxl-poison.sh: test scanning past fully mapped partitions
Alison Schofield