Stefan Egli commented on OAK-4907:

Thx [~chetanm], a few comments on the points:
bq. 1. Instead of special casing for EMPTY ...
I see, I guess while the two variants aren't really equivalent they are both 
not ideal. In theory it should also be OK for the ChangeCollector to add a 
_new_ CommitContext (which it indeed doesn't do now) when it's not there - and 
in this case the check for EMPTY would avoid that. But we don't have that at 
the moment, so I guess we can go with the assumption that 'someone else' sets 
the CommitContext (as is happening in commit() atm). I guess what I'm saying is 
that I find both solutions suboptimal, but I'll go for your variant.
bq. 2. I see following 3 boolean vars always being set to true
good point - now after the dust (of initial development) has settled it's 
indeed obvious that the variables can be combined into one.
bq. 3. Log the limits/config
will do
bq. 4. Keep the child name as instance variable
good idea
bq. 5. Use Iterables#addAll.
good idea
bq. 6. testNull test is failing for me
indeed does for me too - that's due to the late-incoming addition of skipping 
bq. May be we should split this class in two. 
bq. Also some coverage around overflow case would be good to have

> Collect changes (paths, nts, props..) of a commit in a validator
> ----------------------------------------------------------------
>                 Key: OAK-4907
>                 URL: https://issues.apache.org/jira/browse/OAK-4907
>             Project: Jackrabbit Oak
>          Issue Type: Technical task
>          Components: core
>    Affects Versions: 1.5.11
>            Reporter: Stefan Egli
>            Assignee: Stefan Egli
>             Fix For: 1.6
>         Attachments: OAK-4907.patch, OAK-4907.v2.patch
> It would be useful to collect a set of changes of a commit (eg in a 
> validator) that could later be used in an Observer for eg prefiltering.
> Such a change collector should collect paths, nodetypes, properties, 
> node-names (and perhaps more at a later stage) of all changes and store the 
> result in the CommitInfo's CommitContext.
> Note that this is a result of 
> [discussions|https://issues.apache.org/jira/browse/OAK-4796?focusedCommentId=15550962&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15550962]
>  around design in OAK-4796

This message was sent by Atlassian JIRA

Reply via email to