[
https://issues.apache.org/jira/browse/OAK-5022?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15621798#comment-15621798
]
Michael Dürig commented on OAK-5022:
------------------------------------
bq. Could this be handled lazily
In the current implementation this would be lazy by default. That is, the diff
would only be calculated as much as is required and as long as you keep calling
{{EventIterator.next()}}.
> add includeSubtreeOnDelete flag to OakEventFilter
> -------------------------------------------------
>
> Key: OAK-5022
> URL: https://issues.apache.org/jira/browse/OAK-5022
> Project: Jackrabbit Oak
> Issue Type: Improvement
> Components: jcr
> Affects Versions: 1.5.12
> Reporter: Stefan Egli
> Assignee: Stefan Egli
>
> (Originally reported as JCR-4037, but moved to Oak as a result of introducing
> the OakEventFilter in OAK-5013. From the original description: )
> In some cases of observation it would be useful to receive events of child
> node or properties of a parent/grandparent that was deleted. Currently (in
> Oak at least) one only receives a deleted event for the node that was deleted
> and none of the children.
> Suggesting to (re)introduce a flag, eg as follows to the
> JackrabbitEventFilter:
> {code}
> boolean includeSubtreeOnRemove;
> {code}
> (Open for any better name of course)
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)