Alex Parvulescu created OAK-6141:
------------------------------------

             Summary: Membership writer setMembers doesn't properly cleanup tree
                 Key: OAK-6141
                 URL: https://issues.apache.org/jira/browse/OAK-6141
             Project: Jackrabbit Oak
          Issue Type: Bug
          Components: core, security
            Reporter: Alex Parvulescu
            Assignee: Alex Parvulescu


I'm pretty sure this [0] is supposed to be instead:
{noformat}
group.getChildNode(UserConstants.REP_MEMBERS_LIST).remove();
{noformat}
 in its current shape, this will fail to cleanup preexisting members.

Also, I'd prefer if this would actually: 1. cleanup, 2. call existing 
#addMembers method to reduce code duplication.

[~anchela] thoughts?

[0] 
https://github.com/apache/jackrabbit-oak/blob/trunk/oak-core/src/main/java/org/apache/jackrabbit/oak/security/user/MembershipWriter.java#L248



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Reply via email to