[ 
https://issues.apache.org/jira/browse/OAK-6511?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Robert Munteanu resolved OAK-6511.
----------------------------------
    Resolution: Fixed

> Switch to official OSGi versioning annotations
> ----------------------------------------------
>
>                 Key: OAK-6511
>                 URL: https://issues.apache.org/jira/browse/OAK-6511
>             Project: Jackrabbit Oak
>          Issue Type: Task
>          Components: parent
>            Reporter: Robert Munteanu
>            Assignee: Robert Munteanu
>             Fix For: 1.8, 1.7.6
>
>
> When building Oak, several warnings are printed related to the usage of the 
> bnd versioning annotations:
> {noformat}[WARNING] Manifest 
> org.apache.jackrabbit:oak-auth-external:bundle:1.8-SNAPSHOT : 
> aQute.bnd.annotation.Version annotation used in class 
> org.apache.jackrabbit.oak.spi.security.authentication.external.package-info. 
> Bnd versioning annotations are deprecated as of Bnd 3.2 and support will be 
> removed in Bnd 4.0. Please change to use OSGi versioning 
> annotations.{noformat}
> Since it's a mostly mechanical change with a limited number of scenarios I 
> propose to just do it outright.
> {noformat}$ git grep aQute.bnd.annotation | wc -l
> 85{noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to