[EMAIL PROTECTED] wrote:
Bonjour,

Je poste cette petite astuce pour permettre aux utilisateurs de s'authentifier sur un PDC samba. Par défaut les attributs sambaPwdCanChange, sambaPwdLastSet et sambaPwdMustChange ne sont pas attribués aux utilisateurs créés et samba affiche dans les logs un message :

sam_account_ok: Account for user 'xxxxx' password must change!.

Pour remédier à ce problème il faut mettre à l'utilisateur l'attribut [UX] (le mot de passe n'expire jamais)

C'est aparement un changement de comportement de samba et non pas un bug OBM



Bonjour,

merci pour ce retour.

Nous devons valider que cette modification n'entraîne pas de disfonctionnement avec les version <3.0.25 (actuellement utilisés dans les distribution RHEL5 et Debian Etch) pour mettre cette modification dans la version générique d'OBM.

Si vous avez besoin d'ores et déjà de ce fonctionnement, il faut modifier le fichier 'auto/libperl-OBM/OBM/Entities/obmUser.pm' et remplacer la ligne 396 :
$self->{"properties"}->{userobm_samba_flags} = "[U]";
par :
$self->{"properties"}->{userobm_samba_flags} = "[UX]";

Cordialement



_______________________________________________
Obm mailing list
Obm@list.aliasource.fr
http://www.list.aliasource.fr/mailman/listinfo/obm

_______________________________________________
Obm mailing list
Obm@list.aliasource.fr
http://www.list.aliasource.fr/mailman/listinfo/obm

Répondre à