On Tue, Oct 19, 2010 at 5:38 PM, Patrick BOSSARD <patrick.boss...@ifremer.fr
> wrote:

> Bonjour à tous,
>
> J'ai mis a jour obm  2.3.8 en 2.3.12, et depuis j'ai des soucis lors de
> la suppression d'evts :
> > Warning: pg_query() [function.pg-query]: Query failed: ERROR: column
> > "deletedevent_event_ext_id" of relation "deletedevent" does not exist
> > LINE 1: INSERT INTO DeletedEvent (deletedevent_event_id,
> > deletedeven... ^ in /usr/share/obm/www/obminclude/phplib/db_pgsql.inc
> > on line 96
> > Database error: Invalid SQL: INSERT INTO DeletedEvent
> > (deletedevent_event_id, deletedevent_event_ext_id,
> > deletedevent_user_id, deletedevent_origin, deletedevent_type,
> > deletedevent_timestamp) VALUES (31810,
> >
> '708f2841632b97cdc6681ccc163766393e936d33b222cf625e48d5f585df1f47688d62dfa8b4a9d10a4e5c3532576b037d44f5f9e5dfc7862698b4e45b6dd6e184cddd5b2c2c0369',
> > 3,'obm-ui-web-2.3.12', 'VEVENT', NOW())
> > PostgreSQL Error: 1 (ERROR: column "deletedevent_event_ext_id" of
> > relation "deletedevent" does not exist LINE 1: INSERT INTO
> > DeletedEvent (deletedevent_event_id, deletedeven... ^)
>
> ca sent la mise a jour database qui ne s'est pas correctement passée,
> mais l'upgrade ne m'a sorti aucune erreur flagrante (cf logs ci
> dessous), obm-storage semble avoir ete bien mis à jour....
>
> Je pense passer les scripts en manuel, mais y a il qque chose a faire
> avant / de mieux ?
> Quelqu'un à-il une idée de ce qui a pu se paser / de ce que j'ai pu
> faire de mal... ?
> Merci à tous,
>
> Patrick.
>
>
> > vagenda2:~# aptitude install libobm-perl obm-ca obm-certs obm-conf
> > obm-core obm-jdk obm-ldap obm-locator obm-munin-master obm-munin-node
> > obm-opush obm-services obm-solr obm-storage obm-support obm-sync
> > obm-tomcat obm-ui
> > Reading package lists... Done
> > Building dependency tree
> > Reading state information... Done
> > Reading extended state information
> > Initializing package states... Done
> > Reading task descriptions... Done
> > The following packages will be upgraded:
> >   libobm-perl obm-certs obm-conf obm-core obm-ldap obm-locator
> > obm-munin-master obm-munin-node obm-opush obm-services obm-storage
> > obm-support obm-sync obm-ui
> > The following packages are RECOMMENDED but will NOT be installed:
> >   locate
> > 14 packages upgraded, 0 newly installed, 0 to remove and 80 not upgraded.
> > Need to get 10.2MB of archives. After unpacking 147kB will be used.
> > Do you want to continue? [Y/n/?] Y
> > Writing extended state information... Done
> > Get:1 http://deb.obm.org obm/obm obm-munin-node 2.3.12-1 [8460B]
> > Get:2 http://deb.obm.org obm/obm obm-sync 2.3.19-1 [2188kB]
> > Get:3 http://deb.obm.org obm/obm obm-munin-master 2.3.12-1 [4846B]
> > Get:4 http://deb.obm.org obm/obm obm-ui 2.3.12-1 [26.9kB]
> > Get:5 http://deb.obm.org obm/obm libobm-perl 2.3.12-1 [93.6kB]
> > Get:6 http://deb.obm.org obm/obm obm-services 2.3.12-1 [17.0kB]
> > Get:7 http://deb.obm.org obm/obm obm-conf 2.3.12-1 [9776B]
> > Get:8 http://deb.obm.org obm/obm obm-certs 2.3.12-1 [5184B]
> > Get:9 http://deb.obm.org obm/obm obm-ldap 2.3.12-1 [20.9kB]
> > Get:10 http://deb.obm.org obm/obm obm-core 2.3.12-1 [3135kB]
> > Get:11 http://deb.obm.org obm/obm obm-storage 2.3.12-1 [374kB]
> > Get:12 http://deb.obm.org obm/obm obm-locator 2.3.2-1 [4287kB]
> > Get:13 http://deb.obm.org obm/obm obm-support 2.3.12-1 [4620B]
> > Get:14 http://deb.obm.org obm/obm obm-opush 2.3.20-1 [11.6kB]
> > Fetched 5900kB in 3s (1529kB/s)
> > Preconfiguring packages ...
> > (Reading database ... 64437 files and directories currently installed.)
> > Preparing to replace obm-munin-node 2.3.7-2 (using
> > .../obm-munin-node_2.3.12-1_all.deb) ...
> > Unpacking replacement obm-munin-node ...
> > Preparing to replace obm-sync 2.3.10-1 (using
> > .../obm-sync_2.3.19-1_all.deb) ...
> > Unpacking replacement obm-sync ...
> > Preparing to replace obm-munin-master 2.3.7-2 (using
> > .../obm-munin-master_2.3.12-1_all.deb) ...
> > Unpacking replacement obm-munin-master ...
> > Preparing to replace obm-ui 2.3.8-1 (using
> > .../obm-ui_2.3.12-1_all.deb) ...
> > Unpacking replacement obm-ui ...
> > Preparing to replace libobm-perl 2.3.8-1 (using
> > .../libobm-perl_2.3.12-1_all.deb) ...
> > Unpacking replacement libobm-perl ...
> > Preparing to replace obm-services 2.3.8-1 (using
> > .../obm-services_2.3.12-1_all.deb) ...
> > Unpacking replacement obm-services ...
> > Preparing to replace obm-conf 2.3.8-1 (using
> > .../obm-conf_2.3.12-1_all.deb) ...
> > Unpacking replacement obm-conf ...
> > Processing triggers for obm-tomcat ...
> > /usr/share/tomcat/conf/Catalina/localhost /
> > publish /usr/share/obm-tomcat/applis/obm-sync.xml into OBM tomcat
> > server...
> > publish /usr/share/obm-tomcat/applis/solr.xml into OBM tomcat server...
> > /
> > OBM Tomcat already running.
> > Processing triggers for man-db ...
> > Setting up obm-conf (2.3.12-1) ...
> > (Reading database ... 64437 files and directories currently installed.)
> > Preparing to replace obm-certs 2.3.8-1 (using
> > .../obm-certs_2.3.12-1_all.deb) ...
> > Unpacking replacement obm-certs ...
> > Preparing to replace obm-ldap 2.3.8-1 (using
> > .../obm-ldap_2.3.12-1_all.deb) ...
> > Unpacking replacement obm-ldap ...
> > Preparing to replace obm-core 2.3.8-1 (using
> > .../obm-core_2.3.12-1_all.deb) ...
> > Unpacking replacement obm-core ...
> > Setting up obm-core (2.3.12-1) ...
> > (Reading database ... 64449 files and directories currently installed.)
> > Preparing to replace obm-storage 2.3.8-1 (using
> > .../obm-storage_2.3.12-1_all.deb) ...
> > Unpacking replacement obm-storage ...
> > Preparing to replace obm-locator 2.3.1-1 (using
> > .../obm-locator_2.3.2-1_all.deb) ...
> > Waiting for OBM Locator Server shutdown..
> > Unpacking replacement obm-locator ...
> > Preparing to replace obm-support 2.3.7-2 (using
> > .../obm-support_2.3.12-1_all.deb) ...
> > Unpacking replacement obm-support ...
> > Preparing to replace obm-opush 2.3.12-1 (using
> > .../obm-opush_2.3.20-1_all.deb) ...
> > Unpacking replacement obm-opush ...
> > Setting up obm-munin-node (2.3.12-1) ...
> > publish obm_locator_memory into munin-node
> > publish obm_tomcat_memory into munin-node
> > Setting up obm-sync (2.3.19-1) ...
> > Setting up obm-munin-master (2.3.12-1) ...
> > Setting up obm-certs (2.3.12-1) ...
> > Setting up obm-ui (2.3.12-1) ...
> > Setting up libobm-perl (2.3.12-1) ...
> > Setting up obm-services (2.3.12-1) ...
> > Setting up obm-ldap (2.3.12-1) ...
> > [obm-ldap] update configuration file obm_conf.ini....
> > [DONE]
> > Setting up obm-locator (2.3.2-1) ...
> > Installing new version of config file /etc/init.d/obm-locator ...
> > OBM Locator Server started: 7408
> > Setting up obm-storage (2.3.12-1) ...
> > dbconfig-common: writing config to /etc/dbconfig-common/obm-storage.conf
> > *** WARNING: ucf was run from a maintainer script that uses debconf, but
> >              the script did not pass --debconf-ok to ucf. The maintainer
> >              script should be fixed to not stop debconf before calling
> > ucf,
> >              and pass it this parameter. For now, ucf will revert to
> using
> >              old-style, non-debconf prompting. Ugh!
> >
> >              Please inform the package maintainer about this problem.
> > creating database backup in
> > /var/cache/dbconfig-common/backups/obm-storage_2.3.8-1.pgsql.
> > applying upgrade script for 2.3.8-1 -> 2.3.8-2.
> > applying upgrade sql for 2.3.8-1 -> 2.3.9-1.
> > warning: ident method specified but local account doesn't exist.
> > warning: ident method specified but local account doesn't exist.
> > applying upgrade sql for 2.3.8-1 -> 2.3.10-1.
> > warning: ident method specified but local account doesn't exist.
> > warning: ident method specified but local account doesn't exist.
>

il semble que les maj 2.3.11 to 2.3.12 n'ont pas été appliqué, je ne vois
pas de:

>"applying upgrade sql for 2.3.8-1 -> 2.3.11/12-1....."

 connectez vous à la bd et faite un "select * from ObmInfo;" vous devriez
avoir un numéro de version de la BD, si elle n'est pas en 2.3.12, vous
pouvez appliquer les update à la main.



> > dbconfig-common: flushing administrative password
> > Setting up obm-support (2.3.12-1) ...
> > Setting up obm-opush (2.3.20-1) ...
> > Reading package lists... Done
> > Building dependency tree
> > Reading state information... Done
> > Reading extended state information
> > Initializing package states... Done
> > Reading task descriptions... Done
> >
> > Current status: 80 updates [-14].
> > vagenda2:~#
>
>
> --
> Patrick BOSSARD - DOP/DCB/IDM/RIC
> IFREMER centre de Brest
> BP 70 29280 Plouzane FRANCE
> Tel  : 02 98 22 44 09 - Fax: 02 98 22 45 46
> Email: patrick.boss...@ifremer.fr
>
> _______________________________________________
> Obm mailing list
> Obm@list.obm.org
> http://list.obm.org/mailman/listinfo/obm
>



-- 
Sylvain Garcia
Expert OBM Déchu
sylvain.gar...@isynet.org
_______________________________________________
Obm mailing list
Obm@list.obm.org
http://list.obm.org/mailman/listinfo/obm

Répondre à