On 11/27/2017 10:54 AM, Gordon Ross wrote:
I tried after another update yesterday.  Same problem.

After a little more experimenting, and I noticed that copy/paste
between the Windows host and the guest no longer work either.
As I understand it, both copy/paste and resize involve an interaction
between the hypervisor and the guest, and the vmware tools ("guest
additions") are a key part of the "plumbing" for those interactions.
Given that discovery, I suspect this is likely to be a compatibility
problem between the vmware Xorg driver and the vmware tools (provided
by vmware).
I wonder if it would be worth trying to build one of the "open vmware
tools" open-source packages.
Anyone have suggestions which to try?

Hi Gordon,

I personally have not had the best of luck when installing vmware tools on OpenIndiana. Regardless of whether it was ESXi or the workstation player, the screen never auto-resized for me, and the mouse, once captured, would not escape the VM without doing a CRTL + ALT. No matter what I tried, Xorg just wouldn't load the virtual mouse driver.

I also noticed the mouse does not work at all when using the new ESXI/VSphere web client. This came up in discussion last year.

This is actually pretty important because from esxi 6.5U1 onwards, the C++ based vsphere client no longer works.

Most newer Linux distributions (Centos 7, Mint 18, Fedora, etc.) seem to be shipping with these capabilities already build in. Presumably they are all using open-vm-tools, but that's purely conjecture on my part.


A search of the OI-discuss archives suggests there was once such a package.


oi-dev mailing list

Reply via email to