I _think_ the issue is going to be related to how "pkg image-update" deals
with conflicts (i.e. siliently), coupled with the fact that the image I'm
upgrading is from the 2017.10 Hipster ISO and hasn't been updated to any
recent Hipster packages (i.e. no "pkg image-update" run).

As you might have seen in the openzfs PR I'm using to test, I've created a
new AMI that's a Hipster system updated last night. I have a feeling things
will work with the updated system, which would lead me to believe I
"simply" need to continually update (e.g. weekly) the base image that I use
to do the build and upgrade. i.e. this is an inherent issue with IPS
packages and how "pkg image-update" deals with conflicts, which is
disappointing, but not something I intend to solve (or expect to be solved).

With all that said, I left some output that I got from trying to "pkg
install osnet-incorporation@MY_VERSION" below, in case it's helpful.

On Tue, Feb 27, 2018 at 2:30 AM, Alexander Pyhalov <a...@rsu.ru> wrote:

> On 02/26/18 08:48 PM, Prakash Surya wrote:
>
>> Hi,
>>
>> I'm having a problem using ONU to upgrade an OI Hipster system to a
>> nightly
>> build of the illumos-gate. Basically, after I upgrade via ONU and reboot,
>> the system is running the new BE, but the new kernel (and other packages)
>> aren't running (i.e. they're not part of the new BE).
>>
>> I'm guessing this is a result of how I'm setting the PKGVERS_BRANCH
>> illumos.sh variable, where I set it like so:
>>
>> PKGVERS_BRANCH=$(pkg info -r pkg://openindiana.org/SUNWcs | awk '$1 ==
>> "Branch:" {print $2}')
>>
>> Is this how I should be setting this variable? How do others upgrade OI to
>> a nightly build of illumos-gate?
>>
>
> Hi.
> I usually set PKGVERS_BRACNH to RELEASE_MAJOR.RELEASE_MINOR+1.0.0 (where
> RELEASE_MAJOR and RELEASE_MINOR matches OI versions).


​I'm updating the script I use to build, to do this. It still didn't solve
my issue, but this matches the "how to build illumos docs" so it should be
good to do none-the-less.



> To find out what is going on, it would be interesting to see the output of
> pkg update -vv osnet-incorporation@YOUR_VERSION.


​Here's what I see when trying to install to a new BE I created to try and
debug this:​

delphix@openindiana:~/openzfs$ sudo pkg -R /mnt/adsf install
osnet-incorporation@0.5.11-2018.0.0.17099
Creating Plan (Solver setup): /
pkg install: Package system/library/install must be uninstalled before the
requested operation can be performed.
  Reject:  pkg://openindiana.org/system/library/install@0.5.11-2017.0.0.1014
  Reason:  All acceptable versions of 'require' dependency on
system/boot/wanboot@0.5.11-2017.0.0.16778 are obsolete
Package consolidation/install/install-incorporation must be uninstalled
before the requested operation can be performed.
  Reject:  pkg://
openindiana.org/consolidation/install/install-incorporation@0.5.11-2017.0.0.1014
  Reason:  No version matching 'incorporate' dependency
system/install@0.5.11-2017.0.0.1014 can be installed
    ----------------------------------------
    Reject:  pkg://openindiana.org/system/install@0.5.11-2017.0.0.1014
    Reason:  No version matching 'require' dependency
consolidation/install/install-incorporation can be installed
    ----------------------------------------
  Reason:  No version matching 'incorporate' dependency
system/library/install@0.5.11-2017.0.0.1014 can be installed
Package metapackages/build-essential must be uninstalled before the
requested operation can be performed.
  Reject:  pkg://openindiana.org/metapackages/build-essential@1.0-2017.0.0.9
  Reason:  No version matching 'require' dependency
developer/opensolaris/osnet can be installed
    ----------------------------------------
    Reject:
pkg://on-nightly/developer/opensolaris/osnet@0.5.11-2018.0.0.17099
    Reason:  No version matching 'require' dependency
system/library/install can be installed
    ----------------------------------------
Package consolidation/userland/userland-incorporation must be uninstalled
before the requested operation can be performed.
  Reject:  pkg://
openindiana.org/consolidation/userland/userland-incorporation@0.5.11-2017.0.0.9826
  Reason:  No version matching 'incorporate' dependency
consolidation/install/install-incorporation@0.5.11-2017.0.0.1014 can be
installed
Package system/install must be uninstalled before the requested operation
can be performed.
  Reject:  pkg://openindiana.org/system/install@0.5.11-2017.0.0.1014
  Reason:  [already rejected; see above]
Package developer/opensolaris/osnet must be uninstalled before the
requested operation can be performed.
  Reject:
pkg://on-nightly/developer/opensolaris/osnet@0.5.11-2018.0.0.17099
  Reason:  [already rejected; see above]


>
>
>
> --
> Best regards,
> Alexander Pyhalov,
> system administrator of Southern Federal University IT department
>
_______________________________________________
oi-dev mailing list
oi-dev@openindiana.org
https://openindiana.org/mailman/listinfo/oi-dev

Reply via email to