Oh, I think I see the problem. Duh!

To get unstuck, look in src/doc/CMakeLists.txt:

    if (IV_BUILT)
        list (APPEND cli_tools iv)
    endif()

replace that with:

        list (APPEND cli_tools iv)

I'll try to find a better permanent fix.



> On Dec 1, 2016, at 9:52 AM, Larry Gritz <l...@larrygritz.com> wrote:
> 
> The man pages are generated by running the utilities themselves and parsing 
> their help output. We did introduce a change at some point wherein the iv man 
> page would not be built if iv itself was not built (since it couldn't build 
> the man page in that case, and we didn't want an error). Did I botch it 
> somehow? Is it failing to build the iv man page in a situation where iv 
> itself is built?
> 
> 
>> On Dec 1, 2016, at 5:48 AM, Richard Shaw <hobbes1...@gmail.com> wrote:
>> 
>> Larry,
>> 
>> Was the man page for iv intentionally dropped?
>> 
>> Thanks,
>> Richard
>> _______________________________________________
>> Oiio-dev mailing list
>> Oiio-dev@lists.openimageio.org
>> http://lists.openimageio.org/listinfo.cgi/oiio-dev-openimageio.org
> 
> --
> Larry Gritz
> l...@larrygritz.com
> 
> 
> _______________________________________________
> Oiio-dev mailing list
> Oiio-dev@lists.openimageio.org
> http://lists.openimageio.org/listinfo.cgi/oiio-dev-openimageio.org

--
Larry Gritz
l...@larrygritz.com


_______________________________________________
Oiio-dev mailing list
Oiio-dev@lists.openimageio.org
http://lists.openimageio.org/listinfo.cgi/oiio-dev-openimageio.org

Reply via email to